Rockbox

Tasklist

FS#8733 - Database refresh causing system crash

Attached to Project: Rockbox
Opened by Clément Pit--Claudel (CFP) - Saturday, 15 March 2008, 06:10 GMT
Last edited by Steve Bavin (pondlife) - Monday, 17 March 2008, 08:26 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I was updating my database yesterday evening, while listening to music. The plaback started jumping tracks, and I supposed it was beacause my Gigabeat's disk was being used. However, few seconds after, rockbox started displaying messages saying "codec for "xxx" cannot be found". I went to the debug screen to see how far the database refresh process was. It showed -1%, although the number of files scanned actually increased. Then the system crased and showed :
--
*Panic*
Dir entry 9 in sec
tor 0 is not free
54 41 42 41
--
I finally managed to restart the player, but a "firmware not found" screen showed up. I did a chkdsk can on the drive which showed errors, fixed them, installed rockbox back and everything is working properly now.

To avoid such a problem, why would'nt not to just update the database in normal mode rather than in background mode, and forbid access to the player until database refresh is complete ?

CFP.
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 17 March 2008, 08:26 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Take support to the forum or IRC.
Comment by Thomas Martitz (kugel.) - Saturday, 15 March 2008, 17:25 GMT
I don't think the database update caused the disk errors. It actually seems more like the disk errors were there before and the update suffered from it.
Comment by Clément Pit--Claudel (CFP) - Sunday, 16 March 2008, 07:43 GMT
Still, refreshing the database causes disk usage which slows down access to music files. Would it be possible to create an option to have a database refresh in high priority ?

Loading...