Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by kousu - 2008-03-17
Last edited by jdgordon - 2008-04-14

FS#8752 - In Party Mode rockbox thinks applications are media

If Party Mode is on and you try to run an application (by pressing Select) the screen flashes “Party Mode” at you and the application doesn’t run. If you press the button a little longer you will get the File-browser Context menu and try to let you add an App to the current playlist.

Closed by  jdgordon
2008-04-14 10:05
Reason for closing:  Fixed
Additional comments about closing:  

I also couldnt get it to show the playlist options, but I have just removed the playlist catalog items from the menu…

nls commented on 2008-03-18 22:30

The prevention of plugins starting is intended but adding them to the playlist is clearly not :)

kousu commented on 2008-03-18 22:33

Is it? Why is that? The oscilloscope plugin certainly is meant for use during audio being played; what is the rationale behind Party Mode having plugins locked off?

nls commented on 2008-03-18 22:45

Most likely it was made that way because quite a few plugins will stop playback when they are started and rockbox has no way of knowing if the started plugin is one of those.

couldn’t this be solved by some sort of whitelist?

I couldn’t reproduce the adding-rocks-to-current-playlist-in-party-mode part of this report on the e200 w/ r16929, but it does seem that Rockbox will allow you to add any file type (*.txt, *.sdk, etc) to a new or existing playlist through the Playlist Catalog menu, which should probably be prevented.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing