Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Krystalize - 2008-03-20
Last edited by torne - 2009-12-08

FS#8766 - Half downloaded files, playback problems

If you download a file, and break it off halfway (a torrent perhaps) most players will just play what they can find. This counts for Rockbox, but when playback is at the broken-off part, it seamlessly skips to the next song/directory whatever it can find. All good and well so far, but upon closer inspection, the screen still displays the information of the broken file, and clearly has not read the ID-tag of the file now playing.

Closed by  torne
2009-12-08 16:54
Reason for closing:  Out of Date
Additional comments about closing:  

Probably fixed.

Tested only on H100 model.

This has likely been fixed. I can’t reproduce with current SVN. Unless submitter can provide a file that still triggers this behaviour, I think this can be closed.

Note: I tested this with an MP3 file since the submitter mentioned “ID-tags”, but FLAC definitely has issues (FS#9186).

It was mostly fixed with a recent release… But I will try to look for one with the new release, thanks!

On the FLAC issue, I was indeed talking about MP3 files at the time. And I do not think they are the problem now.
I have some FLAC files to test too, so if you don’t hear from me, it’s probably fixed (or I am otherwise not able to post :)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing