Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Playlists
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by dassler - 2008-03-20
Last edited by nicolas_p - 2008-07-06

FS#8771 - Playlist Skips Ahead Randomly

When listening to a playlist in order (as opposed to shuffle), playback will skip several tracks ahead when switching to the next track. The number of tracks skipped and the place at which it skips appears to be random (ie. replaying the track that preceded the skip does not lead to a skip).

If the WPS shows a track counter (9 of 50 or 9/50), the position will be right, but the track that is playing will be wrong (ie. track 9 is supposed to be the track playing and the counter shows 9, but the track that is actually playing might be track 15 and the song information shows this). Also, if you go to the “Playlist” menu and view the current playlist, it will indicate with an icon that the correct track is playing (ie. track 9). If you select that track it will start playing the correct track.

This happens when playing mp3 files and has occurred in all builds I’ve used since installing rockbox in late January.

Closed by  nicolas_p
2008-07-06 13:42
Reason for closing:  Fixed
Additional comments about closing:  

Appears to be the same as  FS#8977  .
Should be fixed by r17891.

Please include the SVN revision you’re reproducing this bug with.

Version r16428-080 currently.

That’s nearly 300 revisions behind the current one, and it looks like you didn’t type out the whole revision number, to boot. Are you using official builds downloaded with either the Rockbox Utility or via the “Current Build” link on the site? You need to update to a current build and verify this behaviour is still happening.

I’m pretty sure that’s been fixed a while now.

Here are the full version numbers. They’re always official builds.
r16293-080212
r16346-080218
r16428-080226

I’m testing the newest build today.
r16727-080321

If it has been fixed, can you point me to the fix itself?

r16549 was the fix

i’m still seeing this behavior on my X5. It seems to be random. I can’t reproduce it. I just updated to the latest build: r17223-080423.

I notice this when a dynamic playlist is generated from a folder of songs made up of a complete album in order by filename(these are also id3 tagged). When listening after a song ends it will just play ahead a few tracks and skip some. It doesn’t seem to skip any when manually skipping with the ‘next’ function. I installed this build specifically hoping to fix this issue but after the second album or so i noticed the skip again. This can be annoying when you are trying to listen to a whole album in order by track#.

The dynamic playlist is generated properly and if i go back to the track and try again, it will proceed properly through the playlist. I can’t figure out any way to reproduce this.

after reading the initial description again, i think the behaviour i’m seeing is a little different. In my case, the track displayed matches the playing track, I’m just getting the wrong order when listening through the album, like i’ll hear #1, #2, #3, #4, #8, #9, etc. where did 5, 6, 7 go ?? who knows, if i go back to #4 again, it will go properly, 4, 5, 6, 7, etc…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing