Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by burny - 2008-03-24
Last edited by speachy - 2024-04-21

FS#8794 - Freeze/Long duration when auto-creating bookmark if there's no free disk space left

Rockbox Version:r16780-080324

Description:
If the “Bookmark on Stop” option is set to “Yes” and there is no free space left on the storage, rockbox freezes/takes a REALLY long time if pressing the Poweoff(=Stop) button, because it cannot save the bookmark(or has to push out the less recent?).

I wondered why rockbox crashed if doing this til I discovered this bug.

Expected behavoiur: Instantls notify user there’s no space left and don’t save the bookmark

How to reproduce:
1. Power on the player, launch rockbox. Make sure there’s enough disk space.
2. Go Settings→General Settings→Bookmarking→Bookmark on Stop→Set to “Yes” 3. Reboot, connect to PC
4. Create a text file which is big enough to consume the rest of your free disk space
5. Restart Sansa into rockbox
6. Play a track
7. Press poweroff (short)

Closed by  speachy
2024-04-21 01:49
Reason for closing:  Out of Date
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

16 years later….

nls commented on 2008-08-11 12:21

I could not reproduce this on my h300 the only thing that happens is that the created .bmark file is empty (which of course insn't correct either)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing