FS#881 - create playlist doesn't work

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 05 February 2003, 18:00 GMT
Last edited by Björn Stenberg (zagor) - Tuesday, 15 April 2003, 22:45 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System
Severity Medium
Priority High
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Using Archos Jukebox Recorder 20. Version 1.28.
Daily Build 030204-1222.

Creating playlist results in empty playlists. I have
my folders in genre/artist/album/ format. When I'm
in a folder and select "create playlist" (F1+scroll to
menu option) the screen shows "creating" playlist
and counts up the number of tracks in the
subfolders (it counts the files correctly) but then
when I go to the new playlist and try to play it, I get
the following:

1 files
End of song list

All of this happens almost instantly and it always
shows 1 file no matter how many tracks it counted

playlist file attached.

Thanks for all of the work you guys put into


This task depends upon

Closed by  Björn Stenberg (zagor)
Tuesday, 15 April 2003, 22:45 GMT
Reason for closing:  Fixed
Comment by Anonymous Submitter - Thursday, 06 February 2003, 21:28 GMT

Addendum: Playlist sporadically works when "create
playlist" is selected by pushing and holding the forward
button rather than hitting play. However not in all cases.
Could it have something to do with playlist size?
Comment by Anonymous Submitter - Tuesday, 11 February 2003, 00:54 GMT

I am also using Jukebox Recorder 20 and can't get playlists
to work at all.

Individual songs play properly when loaded.

When I attempt to load any of my .m3u playlists (created
using Music Match Jukebox from HP) that previously
functioned using just the firmware that came with the
Recorder (1.28), I see the Loading... then the screen
clears, then Playing... 29 Files, then the screen clears again.

If I press >> or << then I see the red light, like the hard
drive is reading the next song into memory, BUT I get no

Perhaps this is something specific to Recorder 20.

Hope this helps. Thanks.

Jim M.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 11 March 2003, 01:04 GMT

Can you generate playlists with the latest version?
Comment by Andreas (crash80) - Monday, 17 March 2003, 00:37 GMT

now my comment:
i tried to use "create playlist" a few times now, but
every time it creates a .m3u in which is mainly crap. i can play it on the
jukebox but there is only played one file. when i hit next it's the same file
again, although the playlist postion counter shows, that it plays the next

if you want i can load up a sample "crap" playlist ;) but you
should try it for your own, i think it'll create the same as on my jb ;)
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 17 March 2003, 00:46 GMT

It works perfectly for me using the latest bleeding edge as
of 2003-03-17 01:30 Stockholm time.

Which version are you using?

There was a file system bug that could cause this, and it is
fixed in the 2003-03-16 daily build.

Comment by Anonymous Submitter - Saturday, 22 March 2003, 15:24 GMT

Tried updating to the latest bleeding edge
(030321-0421) but still having the same problem. I
have my folders organized by genre->artist-->album.
Went into an artist folder which has four albums in a
and tried the following:

1) In the artist folder selected F1 and then pushed
forward on create playlist
2) In the artist folder selected F1 and then held forward
on create playlist
3) In the artist folder selected F1 and then pushed play
on create playlist.

In all three cases I get a M3u file but when I play that
m3u file the red light goes on, the screen goes blank
and about two seconds later I get a message that says
"End of Song List"

I can play playlists that I create on my computer but
none created by rockbox.

I'm using a jukebox recorder 20