Rockbox

Tasklist

FS#8812 - Missing Artist

Attached to Project: Rockbox
Opened by Jonathan Leech (jonathaz) - Thursday, 27 March 2008, 05:39 GMT
Last edited by Steve Bavin (pondlife) - Monday, 31 March 2008, 06:38 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System iPod Mini
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have one track with the Artist as "Beastie Boys and Cypress Hill", the Album is empty.
I have hundreds of other tracks with the Artist as "Beastie Boys", on various albums.
Only "Beastie Boys and Cypress Hill" appears as an Artist in the database.
"Beastie Boys" doesn't appear.
The various albums do appear, as do the tracks.
I suspect the nature of the bug has to do with the artist "Beastie Boys" being a substring of "Beastie Boys and Cypress Hill".
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 31 March 2008, 06:38 GMT
Reason for closing:  Not a Bug
Comment by Paul Louden (Llorean) - Thursday, 27 March 2008, 06:31 GMT
What formats are these files, what tagging format is used, what SVN revision is your build, etc?
Comment by Dominik Riebeling (bluebrother) - Saturday, 29 March 2008, 10:10 GMT
As far as I understood this task this is not a bug but simply an issue with similar values -- "Beastie Boys" is completely different than "Beastie Boys and Cypress Hill" (from tags view) and therefore the latter won't appear below the first one. It's two different values.

If you mean something different please clarify.
Comment by Jonathan Leech (jonathaz) - Sunday, 30 March 2008, 23:40 GMT
"Beastie Boys" and "Beastie Boys and Cypress Hill" are two different Artists, and "Beastie Boys" doesn't appear at all under "Artists".

The files are all mp3, synced via iTunes. The build was the latest daily build as of Wednesday, March 26.
Comment by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 00:35 GMT
Have you updated the database (database settings -> update now) since you added the Beastie Boys songs? What type of tags do the songs have?
Comment by Jonathan Leech (jonathaz) - Monday, 31 March 2008, 05:18 GMT
OK, I am really sorry to waste everybody's time. "The Beastie Boys' shows up, nothing is broken. I think in iPod mode it shows up under "Beastie Boys, The". Rockbox is awesome.

Loading...