Notice: A non well formed numeric value encountered in /sites/ on line 96 Notice: A non well formed numeric value encountered in /sites/ on line 96 Notice: A non well formed numeric value encountered in /sites/ on line 96 Deprecated: Function create_function() is deprecated in /sites/ on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/ on line 845 Deprecated: Function create_function() is deprecated in /sites/ on line 111 FS#8818 : problems playing mp2 on ipods



FS#8818 - problems playing mp2 on ipods

Attached to Project: Rockbox
Opened by Giuseppe Di Marco ( - Friday, 28 March 2008, 18:05 GMT
Last edited by Frank Gevaerts (fg) - Friday, 22 January 2010, 21:09 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I start playing an mp2 file (radio recordings from my DVB-S card) and the hard disk is busy caching it, it's impossible to pause, ffwd/rewind or switch to another music file - when I attempt to do so, the software freezes completely and the original mp2 keeps on playing until the caching process is complete, which might last for up to 90 seconds, depending on the bitrate of the mp2 file. I'm using it on an ipod mini 1st gen, but there's been a report on the forums of another user having the same problem with an ipod nano <>.
This problem only applies to mp2 files; mp3s and aacs play fine.
This task depends upon

Closed by  Frank Gevaerts (fg)
Friday, 22 January 2010, 21:09 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response. There have been many playback-related fixes since. Please open a new report if this still happens
Comment by Paul Louden (Llorean) - Friday, 28 March 2008, 19:03 GMT
What SVN revision is your build?
Comment by Giuseppe Di Marco ( - Saturday, 29 March 2008, 00:30 GMT
It's r16870-080328, downloaded today from the website. I've also tried older builds but they all have the same issues with mp2s.
Comment by Thom Johansen (preglow) - Wednesday, 02 April 2008, 21:18 GMT
Well, all my MP2 files decode just fine on a Nano. Are all the MP2 files you've tested ripped from digital radio transmissions? It might be they contain some weirdness Rockbox doesn't like.
Comment by Giuseppe Di Marco ( - Thursday, 03 April 2008, 00:51 GMT
Yes, they're all ripped from DVB-S, usually exported with the EyeTV software or with MPEG Streamclip. I've uploaded a couple of short recordings (8,4 MB total), if someone wants to test them:
Comment by Michael Sevakis (MikeS) - Thursday, 03 April 2008, 01:18 GMT
The real question is what weirdness do they contain that Rockbox shouldn't handle gracefully though? :)
Comment by Giuseppe Di Marco ( - Thursday, 03 April 2008, 02:30 GMT
I've made some more tests (latest build installed), this time also with some CD tracks encoded to mp2. I seem to have encountered this problem less frequently when dealing with smaller files, or at least it's less annoying since it only hangs for a no more than 15 seconds at a time (usually happens when I pause and select another mp2 file). Alas, I've also noticed more erratic behaviour on my ipod mini 1stgen -- sometimes when it finished playing an mp2 file it started playing it again, rather than playing the next file (also mp2); other times it started playing the next file seamlessly (it was an mp2 recording I've cut into smaller files for testing), while other times it did play the next track with a gap and with track info from the previous file. Alas, as much as I like Rockbox, I can't really use it as my main ipod mini software for the time being...
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 03 April 2008, 06:09 GMT
As far as I can see, there is nothing special about the files, except maybe that the sampling rate is 48000Hz. It could be that the iPod has trouble keeping up with the high bitrate MP2 combined with the higher sampling rate.
Comment by christian (kiese) - Thursday, 03 April 2008, 16:49 GMT
The problem is the antiskip. the time to fill the buffer is to long.

See my thread:
Comment by Giuseppe Di Marco ( - Sunday, 06 April 2008, 19:52 GMT
I had tried older builds but the problem was still there. Until which build has this problem with the antiskip appeared?
Comment by christian (kiese) - Monday, 07 April 2008, 17:06 GMT
the function "antiskip" was in a very old version avilable.
Comment by Steve Bavin (pondlife) - Tuesday, 20 October 2009, 07:54 GMT
Ie this still a problem with a current build? If so, could somebody repost a sample mp2 file for me? If not - or there's no response - we should consider closure...