Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by giuseppe.dm - 2008-03-28
Last edited by fg - 2010-01-22

FS#8818 - problems playing mp2 on ipods

When I start playing an mp2 file (radio recordings from my DVB-S card) and the hard disk is busy caching it, it’s impossible to pause, ffwd/rewind or switch to another music file - when I attempt to do so, the software freezes completely and the original mp2 keeps on playing until the caching process is complete, which might last for up to 90 seconds, depending on the bitrate of the mp2 file. I’m using it on an ipod mini 1st gen, but there’s been a report on the forums of another user having the same problem with an ipod nano <http://forums.rockbox.org/index.php?topic=15974.0>.
This problem only applies to mp2 files; mp3s and aacs play fine.

Closed by  fg
2010-01-22 21:09
Reason for closing:  Out of Date
Additional comments about closing:  

No response. There have been many playback-related fixes since. Please open a new report if this still happens

What SVN revision is your build?

It’s r16870-080328, downloaded today from the website. I’ve also tried older builds but they all have the same issues with mp2s.

Well, all my MP2 files decode just fine on a Nano. Are all the MP2 files you’ve tested ripped from digital radio transmissions? It might be they contain some weirdness Rockbox doesn’t like.

Yes, they’re all ripped from DVB-S, usually exported with the EyeTV software or with MPEG Streamclip. I’ve uploaded a couple of short recordings (8,4 MB total), if someone wants to test them: http://download.yousendit.com/CD2C4E227B839406

MikeS commented on 2008-04-03 01:18

The real question is what weirdness do they contain that Rockbox shouldn’t handle gracefully though? :)

I’ve made some more tests (latest build installed), this time also with some CD tracks encoded to mp2. I seem to have encountered this problem less frequently when dealing with smaller files, or at least it’s less annoying since it only hangs for a no more than 15 seconds at a time (usually happens when I pause and select another mp2 file). Alas, I’ve also noticed more erratic behaviour on my ipod mini 1stgen – sometimes when it finished playing an mp2 file it started playing it again, rather than playing the next file (also mp2); other times it started playing the next file seamlessly (it was an mp2 recording I’ve cut into smaller files for testing), while other times it did play the next track with a gap and with track info from the previous file. Alas, as much as I like Rockbox, I can’t really use it as my main ipod mini software for the time being…

Project Manager

As far as I can see, there is nothing special about the files, except maybe that the sampling rate is 48000Hz. It could be that the iPod has trouble keeping up with the high bitrate MP2 combined with the higher sampling rate.

kiese commented on 2008-04-03 16:49

The problem is the antiskip. the time to fill the buffer is to long.

See my thread: http://www.rockbox.org/tracker/task/8769?pagenum=1

I had tried older builds but the problem was still there. Until which build has this problem with the antiskip appeared?

kiese commented on 2008-04-07 17:06

the function “antiskip” was in a very old version avilable.

Ie this still a problem with a current build? If so, could somebody repost a sample mp2 file for me? If not - or there’s no response - we should consider closure…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing