Rockbox

Tasklist

FS#8826 - Enabling EQ disables crossfade

Attached to Project: Rockbox
Opened by Bertrik Sikken (bertrik) - Saturday, 29 March 2008, 19:39 GMT
Last edited by Marc Guay (Marc_Guay) - Thursday, 03 April 2008, 21:22 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When cross-fade is enabled, enabling and disabling the eq in the sound settings context menu causes cross-fading to be ineffective.

How to reproduce:
* hardware: sansa e260 with r16681
* set all settings to default (hold rec key on start)
* enable crossfade
* play some tracks and skip some to verify crossfade works
* hold select to go into context menu, go to sounds settings / equalizer, enable then disable equalizer.
* skip some tracks: crossfade no longer works

My suspicion is that the pcm latency is set to low when the eq is enabled, but never set back to normal when disabling the eq. I think the low pcm latency makes the crossfade ineffective.

This task depends upon

Closed by  Marc Guay (Marc_Guay)
Thursday, 03 April 2008, 21:22 GMT
Reason for closing:  Fixed
Comment by Dan Everton (safetydan) - Sunday, 30 March 2008, 09:46 GMT
I've verified that the equalizer resets the low-latency setting whenever it exits the menu. However I've cleaned up the low-latency handling a bit. Could you try with a build from r16888 onwards and update this bug if you can still reproduce the problem?
Comment by Marc Guay (Marc_Guay) - Thursday, 03 April 2008, 13:40 GMT
Working super-fine with r16929, but will wait for Bertrik to confirm in case I misunderstood.
Comment by Bertrik Sikken (bertrik) - Thursday, 03 April 2008, 21:13 GMT
Indeed the problem seems to be fixed since r16888.

Loading...