Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by belze - 2008-04-07
Last edited by roolku - 2008-04-07

FS#8859 - Problem with DISCNUMBER in the Database

I am using revision 16976 on a Sansa e200, but this should affect all players.

The database uses the DISCNUMBER-tag to create a view like <discno>.<track>, i.e. 4.01.

But if you tag a set of cds that has more than 9 cds, the ordering inside the database doesn't work correctly anymore, as it sorts like this:

1.01 … 1.20
10.01 … 10.20 ← !
11.01 … 11.01 ← !
2.01 … 2.02

I haven't tried filling up the DISCNUMER-tag with leading zeros, but I never noticed this was necessary on the track-no.

Closed by  roolku
2008-04-07 10:57
Reason for closing:  Not a Bug
Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

The database uses the format string for sorting which is set to one digit for discnumber and 2 digits for tracknumber. If you want more digits to sort correctly, you can adapt the string in tagnavi.config (see http://www.rockbox.org/twiki/bin/view/Main/DataBase#tagnavi_config_v2_0_Syntax )

For example change

%format "fmt_title" "%d.%02d. %s" discnum tracknum title ? discnum > "0"

to

%format "fmt_title" "%02d.%03d. %s" discnum tracknum title ? discnum > "0"

for 2 digit discnumbers and 3 digit track numbers. Note that tagnavi.config will get overwritten with every update, so the better option is to create your own tagnavi_custom.config.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing