Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by PeterD - 2008-04-14
Last edited by nls - 2008-04-28

FS#8889 - Spell file name is ignoreing "A"

Hi,

I have configured RockBox r17103-080414 to spell out file names. It is good. :-)

Unfortunately the letter “A” is being ignored.
For example Einstein-A-Go-Go-20080406.mp3 is spelt out as … n minus minus g …

Other files and plugins with “A”s have the same problem.

Closed by  nls
2008-04-28 18:12
Reason for closing:  Fixed
Additional comments about closing:  

I committed a fix for the voice file generation, it should be in tomorrows voice files.

nls commented on 2008-04-22 14:04

I could not reproduce this in a sim or on my h300. On which player is this happening?
Could you retest with an updated build and an updated voice file?

I have a Sansa e260.

I have seen (well heard) the problem in versions;
r17103-080414 (the original bug report),
r17131M-080419, and tonight I upgraded to
r17253-080427 (with a new voice file).

BTW is the underscore supposed to be spoken? It is not spoken, or even a pause. I should make a point of trying file names with all valid characters. What characters are banned? A null? A slash? What else?

nls commented on 2008-04-27 13:41

only a-z 0-9 + - . and space are handled by the speaking all other chars are ignored. Having a string with chars that are not handled should of course not break spelling anyway.

Listening carefully and repeatedly there might be a sound for “A”, but it is just too short for me to identify it as such. Maybe the recording of that letter has been edited to be too brief for my ears, rather than there being a bug in the code.

There is a philosophical question about haw to handle unwanted input (invalid characters). Personally I would like an “unknown” sound or even putting a sound to every character. ;-) That would probably take too much memory. What happens in languages other than English that have extra letters?

nls commented on 2008-04-28 16:58

Ok, I tried with the voice file provided on rockbox.org and can definitely understand what you mean, the sound for A is there but is not pronounced the way a person would when spelling a word but rater like when speaking ‘a’ as a word. Which means this is more of a voice file generation issue. Regarding your question, the voice UI is rater English centric and as I said the spelling does not handle any other chars than the ones i mentioned.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing