Rockbox

Tasklist

FS#892 - Font, wps, and lang filenames not saved in system settings

Attached to Project: Rockbox
Opened by Anonymous Submitter - Sunday, 09 February 2003, 06:13 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:27 GMT
Task Type Bugs
Category
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

In struct user_settings, the fields font_file, wps_file,
and lang_file are declared as only 20 characters long,
causing incomplete (wrong) file names to be saved when
the system settings are saved if the file names are
longer than 20 characters.



Firmware: CVS-030125
Model: Jukebox 5000
ROM: 5.06
USB: neg
ATA: 0x300
Mask: 0000

rb_dev@yahoo.com
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:27 GMT
Reason for closing:  Rejected
Comment by Björn Stenberg (zagor) - Sunday, 09 February 2003, 09:07 GMT

This is not a bug, it is the designed and documented
behaviour: http://rockbox.haxx.se/lang/
Comment by Anonymous Submitter - Sunday, 09 February 2003, 11:19 GMT

Although this limitation is documented for the language and
font files, there is no mention of a file name length
limitation in the documentation for the wps (http://
rockbox.haxx.se/docs/custom_wps_format.html).

I understand that the config block size is limited because of
where you've chosen to save it on disk, but a max name length
of 20 + 4 for extension seems a bit small. In any case the
limitation should at least be documented on the wps format
doc page.
Comment by Björn Stenberg (zagor) - Sunday, 09 February 2003, 11:27 GMT

Agreed. Documentation updated.

Loading...