Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mbryner - 2008-04-25
Last edited by fg - 2009-12-17

FS#8936 - iPod 80gb: unbeatable lockup while in shuffle mode

Yesterday while using Rockbox in the car on a long trip we had set it to shuffle through a directory of about 300 mp3’s. I turned it off at a gas station, but when we were back on the freeway I noticed it had completely frozen at the end of one of the songs.

I tried resetting it innumerable times w/ <menu><select> combo, but it would just go back to a frozen play screen and no audio output after reboots. Even tried booting into the Apple firmware and back. When we were out of the car, I booted into the Apple firmware (the only way the machine would do anything), hooked up via USB to the laptop, and went into the .rockbox directory. There I found the mp3 that the player was hiccuping on and deleted it. When it rebooted, it just locked up immediately, but on the next file. Then I found the .playlist_control file in .rockbox and deleted it. After reboot into Rockbox, it complains about missing the Playlist Control File, but creates it and works normally again.

TEMP FIX: if you are stuck in a “freeze-loop” and reboots don’t help, go into USB mode and delete the .playlist_control file from .rockbox directory. It will be recreated when you reboot and Rockbox will play again.

For discussion see:
http://forums.rockbox.org/index.php?topic=16595.0

Closed by  fg
2009-12-17 20:50
Reason for closing:  Out of Date
Additional comments about closing:  

Nobody apparently ever reproduced this in one and a half years

If this happens again, it would be useful if you could get a copy of the playlist control file before you delete it. Attach the file to this issue…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing