Rockbox

Tasklist

FS#8966 - Sansa E200 - mp3 file is not played back

Attached to Project: Rockbox
Opened by Sebastian Manciulea (manciuleas) - Monday, 05 May 2008, 19:48 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 06 May 2008, 19:36 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

I have a Sansa E200 with Rockbox r17305 installed and I have some mp3s which cannot be played back. They can be played back with the player from the OF and also with any player I have installed on my Linux box (hence I assume the files are not DRM'ed). I'm attaching a piece from one of the files which exhibit the described problem.

Regards,
Sebastian
   t1.mp3 (256 KiB)
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 06 May 2008, 19:36 GMT
Reason for closing:  Not a Bug
Comment by Paul Louden (Llorean) - Monday, 05 May 2008, 20:57 GMT
Can you verify this with a current build? 17305 is about 85 revisions out of date.
Comment by Sebastian Manciulea (manciuleas) - Monday, 05 May 2008, 22:24 GMT
Tried with build r17392 and it's still not working. I wonder what could be that odd with these files?
Comment by Paul Louden (Llorean) - Monday, 05 May 2008, 22:25 GMT
There's definitely something different about it, as it refuses to play in one of my PC players.
Comment by Sebastian Manciulea (manciuleas) - Monday, 05 May 2008, 22:36 GMT
I've tried with amp, mplayer, vlc, noatun, xine and it works but mpg123 does not play it back.
Comment by Sebastian Manciulea (manciuleas) - Tuesday, 06 May 2008, 01:03 GMT
I might have a hint. Rockbox uses the libmad library for mp3 decoding. mpg123 uses the same library, hence it seems that the problem is with libmad.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 06 May 2008, 07:43 GMT
The file is corrupt. It has CRC protection enabled, but the CRC is 0x0000 in all frames. The libmad decoder checks the CRC and discards all frames with invalid checksums.
Comment by Sebastian Manciulea (manciuleas) - Tuesday, 06 May 2008, 18:07 GMT
Thank you for your help. I'll just re-encode the files then.

Loading...