Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System iPod Nano
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Jens - 2008-05-06
Last edited by Paul Louden - 2008-07-01

FS#8970 - iPod Nano: Device freezes when enter Quick Screen

When entering the Quick Screen (press and hold the Menu-button while on WPS), the options will be shown (but parts of the title information from the WPS are also still displayed) and the whole devices freezes. It then needs to be resetted hard (holding Menu and select).
The Quick Screen also appears when holding the menu-button in the main or any other menu.
I tried different themes (the default one included) and the current rockbox-version r17397-080506.

Closed by  Paul Louden
2008-07-01 21:44
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in SVN

Jonathan Gordon commented on 2008-05-07 07:23

I couldnt reproduce this on my nano or e200. have you got voice enabled?

Jens commented on 2008-05-07 17:10

No, voice is disabled at all. After changing to the default theme und reboot the nano, all works fine I just discover so there seems to be a problem with the themes. I tried BlackGlassMgrbis (which worked well in the past and now also crashes) and Clix_Autumn. Were there some changes in des last days/weeks in rockbox who could cause this misbehaviour? I am absolutly sure that it worked with the BlackGlass_MGrbis theme since I use rockbox, but now it won’t.

Jonathan Gordon commented on 2008-05-07 22:21

can you gimme a link to either of these themes? the QS should work with all themes

Jens commented on 2008-05-08 04:23
Jonathan Gordon commented on 2008-05-10 10:22

I dont know what to say… I tried them on my nano and couldnt get it to freeze…

Jens commented on 2008-05-10 12:24

very strange, I didn’t change much options from the default installation since I installed rockbox some time ago. I only updated it from time to time. Is there a new bootloader since my installation about 18 month ago? I think I’ll delete rockbox completly from my nano and install it again, may that works.
Thanks for now for your testing, I’ll comment here if it work after the new install.

Jonathan Gordon commented on 2008-05-10 12:32

yes, I think thats too old to be using the 2nd core so you probably need to update the bootloader…

Jens commented on 2008-05-10 15:42

ok now, I deleted the bootloader with the installer, formated the nano with the windows explorer. After a reboot, the original firmware from apple was loaded correctly. Then I installed the bootloader und rockbox over the Rockbox Utility, added the two themes mentioned above… and after changeing the theme, it crashes when holding the menu-button, as before.
But with some testing, I think I just found the source of the problem: After changing the Language back to english, everything works fine. Seems that the german translation cause the Theme (ur UI) to crash, maybe because the text of the menu is longer. So, if you want to reproduce the problem, you have to set the system-language to german and then hold the menu-button inside the settigs or wps-screen to enter the Quick Menu. I don’t know what exactly causes rockbox to crash, but if there is no simple solution, i don’t mind using it with the english translation. But maybe some german user will have this problem also.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing