Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by djharvey - 2008-05-20
Last edited by nls - 2010-10-25

FS#9016 - AC3 Playback on iRiver H140

Whenever I try to play an AC3 file (and I’ve tried multiple) on my Rockboxed iRiver H140, the unit freezes. I can then only reset via the reset button on the bottom. All other files (that I know of, mostly OGG Vorbis and MP3) play just fine. It didn’t do this with the build I had from a few months (?) ago. (Sorry, I know it’s aggravating and terribly unhelpful; but when I upgraded, I overwrote the old build, so I’m not certain what build the old one was or even when I got it.)

Build is current (r17585-080518).

Closed by  nls
2010-10-25 10:18
Reason for closing:  Out of Date
Additional comments about closing:  

No response for months

Oops, I realized that this was put in the category “Applications.” It should be “Codecs,” I think.

Hi David,

Does this happen with any AC3 file? My sample one seems ok here. Maybe you could pop an example file up somewhere?

It does, at least with all of the ones I have currently.

I’ve posted a zipped file here:

http://harvey.aristotle.net/18. Orthanc.zip (roughly 3.5MB).

Hmmmmmm, I just tried it with the simulator (which uses 17585-080520), and it seems to work fine. However, when I dropped it from the simulator’s build onto my H140, instead of playing (and freezing, thankfully), it now gives me “Codec Failure.”

Sooooo, my guess is that the simulator’s codec files aren’t an exact match for what actually goes on the player, am I right? So my test actually doesn’t prove or disprove anything, lol.

nls commented on 2008-05-20 18:43

The simulator is not an emulator and as you say it does differ from a real target.
Try this.
Check your h140 disk for errors (using chkdsk, fsck or whatever your OS provides).
Unzip a fresh rockbox build overwriting your current one.
(maybe check if the file plays in a player on a computer (the actual file on your h140)).

Hi David,

Sadly, your file (in isolation) plays fine on my H300, as well as on the simulator.

Maybe it’s a problem when you have different foramts (or particular files) mixed? e.g. buffering an AC3 after an OGG or something wacky?

Are your files split files from dvd or from a big ac3 file?

Is this error still occuring? Otherwise I would tend to close this bug report as it is outdated by far.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing