Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To No-one
  • Operating System Sansa c200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by tupari - 2008-05-21
Last edited by jdgordon - 2008-07-08

FS#9018 - MicroSD cards cause boot problems on e200/c200

Something in recent builds of Roxckbox has broken usb connectivity on my c240. I have to reinstall the original firmware following instructions on this page:
http://forums.sandisk.com/sansa/board/message?board.id=c200&thread.id=2028

and after I do that my sansa becomes visible as a disk again, but I can’t run Rockbox.

Can someone tell me how to download an old build so I can get rockbox working again with usb?

Closed by  jdgordon
2008-07-08 14:40
Reason for closing:  Not a Bug
Additional comments about closing:  

not really anything we can do about this… just remember to eject the sd chip before plugging usb? or replug usb when its already in the of

OK I’ve tried as far back as the April 20 build and it is still broken. Unfortunately there are no older builds stored on http://download.rockbox.org/daily/sansac200/

Rockbox doesn’t officially have it’s own USB mode. Currently in order to access the Sansa as a drive, you need to boot into the original firmware. It sounds to me like to stumbled across an accident activation of it.

I see my last comment got lost.

Yes I know rockbox doesn’t have its own usb mode, but something broke the native usb connectivity. If I plug in the usb cable rockbox would boot the native software, but the native software usb was broken until I reinstalled it.

I finally came across the entry in the wiki that told me I needed to eject the microsd card before plugging in the cable, and that solved my problem. This didn’t used to be a problem for me.

Until the real problem is fixed, perhaps when rockbox detects usb and a microsd card is in the slot it should display a warning on screen before going right into the native software.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing