FS#9057 - playback skipping problem

Attached to Project: Rockbox
Opened by Sanggon, Lee (isanggon) - Saturday, 31 May 2008, 16:52 GMT
Last edited by Paul Louden (Llorean) - Sunday, 01 June 2008, 05:35 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After v.17109, rockbox playback system is so nicer than before. And I use current playback system, too. But sometimes when I try to skip playing track, current track repeted.
This problem was randomly present before v.17109, too. but this problem occurs more frequently after v.17109. I tried official build, too and, had same result. It's more frequently occur when processor have heavy load.
and after v.17109(or maybe later), when I first access playlist, an error massage printed(but works correctly. when I revert playback system to v.17108, this error massage was gone.).
This task depends upon

Closed by  Paul Louden (Llorean)
Sunday, 01 June 2008, 05:35 GMT
Reason for closing:  Invalid
Comment by Paul Louden (Llorean) - Saturday, 31 May 2008, 17:57 GMT
You're talking about a build 500+ builds ago. What's the most current build you've tested with? What's the error message (just telling us one happens isn't very useful if you don't include the text of it). You mention "I tried official build too." ALL tests should be with clean (no patches) builds. Were all tests with unpatched builds?
Comment by Sanggon, Lee (isanggon) - Sunday, 01 June 2008, 02:08 GMT
I tested official 17601 build also. It had same problem except playlst error massage. Maybe error massage fixed. but skipping problem was still there. I found similor problem in rockbox forum.
please see johnk's report.
Comment by Paul Louden (Llorean) - Sunday, 01 June 2008, 02:17 GMT
This bug report only mentions the error message. Does the error message still happen?
Comment by Sanggon, Lee (isanggon) - Sunday, 01 June 2008, 05:04 GMT
Error message doesn't exist any more. I'll test the track skipping problem again.