• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Xebozone - 2008-06-05
Last edited by jdgordon - 2008-06-23

FS#9073 - Disappearing album art with viewports

I have just converted my WPS to use viewports for every line due to the lack of right margins, to make setting out easier and to allow for the possibility of different fonts without affecting the position of the text.

One thing i have noticed (and I’m not surprised) is that using viewports makes things slower - metadata takes longer to display (with more disk access needed) and album art is included in this delay. This might be another bug associated with ViewPorts doing too much (or an optimisation issue), but I’m not sure.

The main problem i have noticed is that sections of my album art sometimes disappear, especially when i lock the device, insert a USB cable (before rockbox reboots), or the disk access icon pops up.

These sections missing line up (y-value) with viewports to the right of the album art (I haven’t tried to the left), and the missing section is usually the height of one of the viewport it is lining up with. Sometimes, the missing section is that between two viewports (with the height of the missing section being that between the two viewports).

While this is occurring, the viewport lining up with the missing section disappears too.

Attached are screendumps and my wps file.

Please note that i have intentionally blurred sections of the screendump because i am not ready to release my WPS (if ever).
I have also edited out the WPS to make it easier to read (it is still functional…except for the bug)

I am using revision 17690 on an iPod 5.5G 30Gb

Closed by  jdgordon
2008-06-23 06:27
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

hopefully been fixed… repost with the full .wps if not

Sorry if that is confusing…I should have proof-read my post. Good thing i attached the WPS and images for those who didn’t successfully make sense of what i wrote :)

1) why do you think viewports affects disk access and metadata loading?
2) I’m not certain, but it looks like your issue with disappearing lines is because the main viewport is sort of broken in svn… please try your wps with a build including  FS#9027 .

1) The info for the songs and the album art takes longer to load (with more disk access) than the same WPS without viewports.
2) I do not know how to build with patches. Perhaps you can test it, however

1) nonesense… 2) ive done a build for you… attached

u forgot to attach :P

ARG… bloody thing is more than 2MiB so flyspray rejected it without saying anything :(

nope…i can’t even test it.

Firstly your build isn’t synced to 17690 (so optional tags are not optional)

even after inserting those optional tags (fortunately, i made a backup with the optional tags included)
the WPS won’t work…

does your build have viewport support or am i doing something wrong?

EDIT: I had to modify the viewport syntax to include letters at the end

…with no luck?

If you move the %C album art drawing to the end of the WPS file it will be drawn last and this won’t happen. There are several threads in the forums concerning this problem.

That would require me to have an additional viewport that contains the dimensions for the album art.

Besides, the main viewport needs to be fixed anyways.

Please advise on getting the custom build to work so I can test it.

What’s wrong with putting the album art in its own viewport?

Its all very well and good for testing or a quick and temporary fix, but it doesn’t actually fix the bug!

I guess it depends on whether or not *everything* is supposed to be in a viewport. If it’s expected that everything has its own viewport, then it’s not really a hack to put album art in its own. But if it isn’t, then it’s a bug. I’ve personally gotten in the habit of putting everything inside its own viewport, including album art and any loaded & displayed images.

I just can’t get the patched version ( with  FS#9027  ) to work
What is the syntax?
Maybe someone can modify my WPS for me for the purpose of testing to see if  FS#9027  does fix the main viewport.

to Marc:
If everything should have a viewport, the main viewport should be one of those viewports, and it is…but it isn’t working properly, as it seems.

the only difference ebtween the build i gave and svn is that it doesnt have the optional params… you dont need to change anything else… I’ll put up another build in a while afgter i resync that patch

ok…thanks, but for some reason it didn’t work, even with the optional tags included

I tried what you suggested, Marc.

Putting album art in another viewport made no difference.

Also, i had to define album art as:
for it not to offset itself in the viewport placed in the correct location.
(instead of:

I also discovered that the line:
can be placed OUTSIDE the viewport. I thought the syntax was:

but it is actually:
%Cl|offset x|offset y|dimensionX|dimensionY|

this should be updated in the cutstomWPS page (and possibly the manual, if it exists there)

even so…placing the album art in another viewport did not solve the problem.
Maybe when i can test  FS#9027  it will work

In fact, some of the top of the album art was cut off when declaring it in a separate viewport now - even worse!

(before it was just the middle, as shown in the screen dumps i attached at the top)

strange…the top only cut off once ever. Maybe it isn’t because of the other viewport.

What i did realise, however, is that the text in the middle disappears whether there is album art or not (ever since declaring album art in a separate viewport)
I don’t think it was like this when album art was declared in the main viewport.

still doesn’t work! - the WPS won’t display, even with optional tags

What is the syntax for the patch?

there is no change to the %V tag. none… nada… bah, zip your wps up with the required bmp’s and ill look at it over the weekend…

it’s not just my WPS

CabbieV2 won’t work either with this patched version!

in fact, only “boxes” works

Not even any of the other defaults!

Perhaps this version doesn’t support tiled images?

nope…it does

I don’t want to send my bmps which is the reason i blurred my image in the first place. I’m computer savvy - i can diagnose the problem myself:

I commented out all the viewport tags and the album art tags - still didn’t work

I then commented out the progress bar - worked (but without viewports) - i knew something was up!
From  FS#9073 :
“The %P tag has been removed” You never told me this!

Then I uncommented album art - still worked (still without any viewports)

Once i uncommented a viewport things stopped working again.
I’m not stupid. there is something wrong with this patched version.

I even tried the new CabbieV2 from  FS#9027  from you (jdgordon) with no luck
Maybe it’s an iPod problem?

I modified boxes (the only working default WPS)
by adding this line at the top:

Clearly there is there is either something wrong with that syntax, with the patch, or with my device…because it doesn’t work either.

Comment by Mark (Xebozone) - Thursday, 05 June 2008, 20:22 GMT+8

“I don’t think it was like this when album art was declared in the main viewport.”

Whether album art has been declared or not, i still get an error here! The problem may be more deep then initially thought.
Perhaps after a certain number of viewports/specific order/specific sizing something messes up, causing one (or more?) to behave improperly

Here are those threads I mentioned earlier, perhaps they contain some useful information regarding the original bug report:

Placing the icons at the top in a separate viewport solved the problem.

This should be a temporary fix, however - it doesn’t solve the problem with the main viewport, which is what this bug is reporting.


Available keyboard shortcuts


Task Details

Task Editing