Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System iPod 4G Color
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Veloz - 2008-06-16
Last edited by linuxstb - 2008-07-17

FS#9097 - r17715 messes up iPod Photo display

Change made in r17715 messes up screen colors on iPod photo, especially noticeable in themes with photo backgrounds.

Colors appear jumbled or swapped, i.e. white becomes green, etc. Initial Rockbox boot screen also appears jumbled.

Closed by  linuxstb
2008-07-17 10:10
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in SVN r18079

I have this same problem are all the latest versions doing to you too?

Veloz commented on 2008-06-20 21:26

Yes, at least all of the ones I tried Monday, until I got back to r17714. I have not updated since then. The latest release I tried was r17727. I think I’ll wait to see some adjustments to the display code before updating again.

Ok well i will leave a comment when they got a release that works i get on every day and update it to see if it works correctly and currently on like version 17756 i think and it still is like that

I too have this problem. And I’m grateful for the knowledge of which builds are and are not affected. I’ll continue to run r17714 until this is resolved, because Rockbox was utterly unusable with this bug; the screen was horrendous and unreadable in all but monochrome themes.

I also notice the release notes for r17715 state that some code was “blind-copied” from iPod linux to resolve another bug with colour display. It would seem obvious that this is what has broken it. Are there iPod colour/photo users who aren’t affected by this issue?

Daniel i just noticed that too i was reading through the IRC on june 19th someone was talking about it and they said that exact same thing it was between 17714 - 17715 that they got codes from ipod linux

If you would like the lated working version download this: http://download.rockbox.org/daily/ipodcolor/rockbox-ipodcolor-20080612.zip

THANKS TO LambdaCalculus37 FOR HAVING THIS FOR US :D

PS im still working with the latest versions to see if they work

Veloz commented on 2008-06-25 17:39

Yes, I’m certain that it was that “blind-copied” code that caused the problem. Although, I do find it interesting that the log entry states that it was introduced to FIX a display problem that we (iPod Color/Photo) users were experiencing. However, I was not experiencing any display issues before the addition of the r17715 code.

This makes me wonder if the issue is with specific hardware revisions. I have an iPod Photo 60Gb.

To those that have responded: which iPod do you have?

It does seem to be the obvious cause. Mine’s an iPod photo 30GB. I also had not had any display/colour issues prior to r17715.

hey theyve already provided a patch for this

i took the time to compile it into the r17804 version soo here it is

heres a rapid share link
http://rapidshare.com/files/125714326/rockbox_ipod_color_patch.zip.html

That link doesn’t work for me. Where did you find this patch?

Heres the link to the patch
http://www.rockbox.org/tracker/task/9122

but you gotta compile you own build for it so heres the link to the compiling guide
http://www.rockbox.org/twiki/bin/view/Main/SimpleGuideToCompiling

or you can just download it from rapidshare and extract it to your ipod

I see from the patch notes that mpegplayer still won’t work with the patch, so I’ll stick to r17714 until the official build is fixed. Thanks anyway. At least now we know what’s gone wrong.

same problem

iPod color Model No: A1099

I’m currently using latest working version posted by Adam.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing