Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by PaulJam - 2008-06-28
Last edited by sideral - 2011-05-19

FS#9132 - Freeze in Database

When you often switch between database and file tree with “Follow Playlist” enabled it can happen that rockbox freezes occasionally.

Reproduction:
Reset settings (maybe optional), initialize database (if it isn’t already), then enable “Follow Playlist”. Start playing a track through the database and from the WPS enter the main menu directly (MENU/A-B), and from there enter the file browser. Now enter the WPS again and press SELECT/NAVI to enter the file browser again, so the playing file is highlighted. Press LEFT multiple times until you are in the main menu again. enter the database and press LEFT ⇒ Freeze.

Maybe there is an easier way to reproduce, but i don’t know it.

H300 with r17859

Closed by  sideral
2011-05-19 15:26
Reason for closing:  Out of Date
Additional comments about closing:  

No confirmation that the problem still exists

Marc Guay commented on 2008-07-11 00:41

Can reproduce on H300 w/ r18007, cannot reproduce on the e200 with the same revision. Flash - 1, HDD - 0.

Maurus Cuelenaere commented on 2010-06-06 17:10

Can this still be reproduced?

MichaelGiacomelli commented on 2011-04-17 23:20

There has been a lot of DB fixes since this was reported. Is it still valid? If not, I’ll close it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing