Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#9144 : System -> Rockbox Info -> Current Time doesn't voice properly

Rockbox

Tasklist

FS#9144 - System -> Rockbox Info -> Current Time doesn't voice properly

Attached to Project: Rockbox
Opened by Jim Dunleavy (jim.dunleavy) - Thursday, 03 July 2008, 10:00 GMT
Last edited by Jonathan Gordon (jdgordon) - Saturday, 05 July 2008, 12:30 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On selecting System -> Rockbox Inof, and arrowing down to Current Time,
the voice repeats "curren' curren' curren' ..." until you arrow
away. The time itself is never spoken.
It looks like the refreshing of the time display continually cancels
the voicing.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Saturday, 05 July 2008, 12:30 GMT
Reason for closing:  Fixed
Comment by Jim Dunleavy (jim.dunleavy) - Thursday, 03 July 2008, 10:08 GMT
I'm using iaudiox5, Rockbox Version: r17925-080703.
Comment by Bertrik Sikken (bertrik) - Thursday, 03 July 2008, 13:51 GMT
This problem may be caused by a fix for  FS#8969  (can't find the corresponding commit). IIRC the solution was to refresh this screen twice a second.
Comment by Jonathan Gordon (jdgordon) - Thursday, 03 July 2008, 14:02 GMT
yes, thats the issue.. ill fix it on the weekend
Comment by Jonathan Gordon (jdgordon) - Friday, 04 July 2008, 05:24 GMT
was going to commit this but ran out of time...

Loading...