Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To
    nicolas_p
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by nicolas_p - 2008-07-04
Last edited by Buschel - 2010-02-20

FS#9152 - No sound after seeking or dir skip

It sometimes happens that music appears to be playing, but there is actually no sound. Pausing and resuming solves the problem.
So far, it has happened to me after seeking or skipping directories.

Last spotted on an iPod 5.5G 80GB with r17900

Closed by  Buschel
2010-02-20 19:22
Reason for closing:  Works For Me
Additional comments about closing:  

Seems to work as there were no more complains since >1 year. Can be re-opened if neccessary.

MikeS commented on 2008-07-04 15:27

Yeah, happens to me too but I just never bother to look into these anymore given a particular bug usually involves multiple paths to perform the same function in slightly different ways. No…I’m not bitter. ::)</bitter>

CFP commented on 2008-08-07 12:35

Same here on Gigabeat although I can’t really find a way to reproduce the bug.

I can confirm that this happens regularly (maybe 100% of the time)? on my iPod 5.5G / 80G. Just installed the latest build as of today (r18391) and have had the problem at least since the last build I installed (late April 2008).

I play a music track (MP3), then I hit the fast forward button short+long to advance to the next directory. It then appears to start playing the correct track, but no sound comes out unless I hit pause twice to pause and resume.

I can also confirm that on older builds dir-skip would sometimes hard-lock the iPod requiring a reset. This happened maybe every 10 times I did it? I’m not sure if this is still there; it may have gotten fixed. I know that dir-skip used to work at least some of the time, but now it doesn’t seem to work at all without the no-audio problem.

I don’t get the no audio issue, but dir skip seems flaky in two other ways:
- The (default) WPS takes ages to refresh when album art is in use, and displays junk sometimes for a while such as playback time of 76867834:87.
- Fast forward sometimes fails to work shortly after a dir skip
I’m using skip to random directory if that’s relevant.

obo commented on 2008-12-12 22:14

As well as silence I still get occasional hardlocks - last was in the mpa codec, arm7tdmi/libgcc.a, function __udivsi3

chiming in here to confirm this is 100% reproducible with version 3.0 on 5.5G/80Gb Ipod. i just start an album playing, with random next directory (not sure if this is necessary), then click and click-hold the right button to skip the album. the next album comes up and starts playing with no sound. only way to get sound back is to stop and start the song. very annoying.

e200 & r19391 - With auto-dir change set to random I can consistently produce a hardlock when skipping directories. Cannot reproduce if it’s simply set to Yes.

still happens?

Should be closed, as there was no update or failure report since >1 year. Any objections?

CFP commented on 2010-02-20 13:38

I agree. The bug seems to have been fixed, since it didn’t appear on my target for a long time now.
CFP.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing