Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Marc_Guay - 2008-07-04
Last edited by Marc_Guay - 2008-07-15

FS#9153 - Data Abort on boot and quick resume playback

Sansa e200 & r17925

I’ve been trying to reproduce this bug for a while now but can’t seem to narrow it down any further so I’ll describe it as best I can and hope that either someone else is experiencing the same thing and can add to it or that someone can figure out what’s happening based on the information I’ve got.

This began a month or two ago, and unfortunately because it’s not reproducible I can’t narrow the revision down (easily or quickly, at least). I usually shut down the player from the WPS screen with a simple long-power, and restart it by turning it on and quickly pressing play either when the splash screen is showing or right after the main menu appears. I’d say about 3/10 times I do this I get a data abort error. It seems to only happen with FLAC files. I have not had it crash under any other circumstances.

Seeing as a push for a release is happening, I thought I’d report this now as it is a playback-related bug and is not an uncommon way of using the player.

Closed by  Marc_Guay
2008-07-15 17:09
Reason for closing:  Fixed
Additional comments about closing:  

After a few days of use, it looks like the problem is gone. You are awesome.

If it helps at all, once the data abort happens and after the device has been rebooted, pressing play again will cause the error to reoccur. The only way to stop the cycle from repeating is to select a fresh song.

I think I've fixed this in r18009, but I saw it on Vorbis files, and not necessarily immediately after boot.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing