Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Playlists
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by vmh - 2008-07-07
Last edited by nls - 2008-10-13

FS#9163 - Current playing Song in Playlist viewer

This patch addresses two issues concerning the current playing song in the Playlist viewer:

a)
After starting the Playlist viewer, the currently (last) playing song is not in the visible area:
Recipe to reproduce it:
1. the playlist should have more entries than the screen lines
2. play the last entry in the playlist
3. open the playlist viewer: the playing song is not visible (need to scroll 1 down)

b)(not a bug)
The currently playing song is always the last in the visible area:
1. the playlist should have more entries than the screen lines
2. play a song which position is greater than the number of lines on your screen
(e.g. if your display can show 10 lines then choose the 11th or above)
3. start the playlist viewer: the current playing song is the last on the list.
I’m not interested in the songs already played, but the songs that will come. Without the patch I always have to scroll down. With the patch the current song will show on the 2nd position in the list.

I adressed two problems I encountered in the playlist viewer, but the changes I made is in the file list.c. I don’t think it has consequences on other lists.

Closed by  nls
2008-10-13 12:18
Reason for closing:  Fixed
Additional comments about closing:  

I committed an alternate fix to the issue with the selection ending up off-screen which was imho more correct.
If you still want to change the list behavior please post a separate patch for that.

vmh commented on 2008-07-07 19:08

The scrolling behaviour shouldn’t be changed, only the initial value …

vmh commented on 2008-07-07 20:16

hopefully the last …

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing