Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#9212 : Pictureflow + music together

Rockbox

Tasklist

FS#9212 - Pictureflow + music together

Attached to Project: Rockbox
Opened by Daniel Siebrecht (DimensionSix) - Thursday, 24 July 2008, 19:39 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Thursday, 24 July 2008, 20:57 GMT
Task Type Bugs
Category Applications
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Last time I updated my build, I could view Pictureflow while music was playing.
How I reproduced this:
- Delete settings at boot
- load a config
- load a theme
- play some music
- start pictureflow
Can someone try to reproduce it?

The interesting thing is that Pictureflow worked nice together with music. Only the loading of the tracklist took some time.

I use H320 with r18096
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Thursday, 24 July 2008, 20:57 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Expected behaviour. Even if it were unexpected, I'd call it a feature.
Comment by Nicolas Pennequin (nicolas_p) - Thursday, 24 July 2008, 20:56 GMT
Funny that you'd file that as a bug :)
It's actually perfectly normal. It happened because the buffer wasn't full, so there was enough free memory to load the pictures without having to stop playback. We tell users to stop playback before using the plugin because most of the time the buffer is full so there's no room left for the pics.
The loading of the tracklist took longer than usual because the CPU was busy doing other things (like decoding music).

Loading...