Rockbox

Tasklist

FS#9216 - Data abort error playing SAP files

Attached to Project: Rockbox
Opened by Mark Fawcus (yapper) - Sunday, 27 July 2008, 03:53 GMT
Last edited by Dave Chapman (linuxstb) - Sunday, 27 July 2008, 10:50 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System iPod 1G/2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Attempting to play SAP files using r18125 gives data abort. I've tried multiple files from http://asma.atari.org/ and all fail in the same way.
This task depends upon

Closed by  Dave Chapman (linuxstb)
Sunday, 27 July 2008, 10:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in SVN r18126
Comment by Dominik Riebeling (bluebrother) - Sunday, 27 July 2008, 07:25 GMT
This seems to be a metadata issue -- if the database tries updating the system crashes with a data abort immediately. Reproducable on e200, mr100 and mini2g.
Comment by Dave Chapman (linuxstb) - Sunday, 27 July 2008, 07:28 GMT
I haven't tested, but a possible fix could be to change line 233 of apps/metadata/asap.c from:

info = (struct module_info *) buf;

to

info = (struct module_info *) ((buf + 3) & ~0x3); /* Align struct to 4-byte boundary */
Comment by Mark Fawcus (yapper) - Sunday, 27 July 2008, 10:16 GMT
@Dave:
I get 'metadata/asap.c:233: error: invalid operands to binary &' with your suggested fix.
Comment by Dave Chapman (linuxstb) - Sunday, 27 July 2008, 10:50 GMT
I was missing a typecast - I've now tested this fix, and it seems to work, so I've committed it to SVN and will close this task.

If anyone gets more data aborts, please request this task is re-opened.

Loading...