• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by hatchetman82 - 2008-08-03
Last edited by MikeS - 2009-02-13

FS#9236 - latest rockbox build freezes on sansa e200 v1 when connecting usb to pc

i turn the player on, everything is fine.
while its on i connect the USB cable to my computer (running winXP SP2) - through a 4 port USB hub, if that matters.
the player displays a USB plug icon, but the computer reports an error (”unrecognized usb device”).
after unplugging the player it still displays the USB plug icon and doesnt respond to anything - i had to shut it down by ohlding down the power button.

Closed by  MikeS
2009-02-13 01:40
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This issue sould be fixed with r19819.

Hi, I just downloaded rockbox and think it has great potential, but I’m having the exact same problem you are. Although I am connected directly to my computer no usb hub. Also I have songs and an audiobook on my e200 in the original firmware but they do not show up on the rockbox set? Any help, ideas?

the problem isnt critical - if you connect the device to the USB port while its off it’ll turn on and boot the original firmware (after a short black bootloader screen) - while in that mode you can copy files over to the player without a hitch.
after im finished copying the files i disconnect it, shut it down and power it back on (this time it boots rockbox).
then all thats needed is to refresh your music database, and violla.

still annoying though …

There is no working USB stack for the Sansa’s (or Ipods). Use the original firmware. The freezing is not supposed to happen though, it should reboot into the OF.

The freezing is not supposed to happen though, it should reboot into the OF.

the freezing only happens if you plug the USB _while the device in on_.
if you plug it in while its off then, just like you said, it boots the original firmware.

it would still be better if it would gracefully pop up an error mwssage saying something along the lines of “USB not supported at present, boot to original firmware” instead of freezing when you plug it in when its turned on …

It’s _supposed_ to reboot into the OF for you (and often does).

I don’t know if it is any help, but using Linux I can grep this out of syslog…

Aug 19 10:42:18 c13 kernel: usb 3-1: new full speed USB device using uhci_hcd and address 6
Aug 19 10:42:23 c13 kernel: usb 3-1: device descriptor read/all, error -110
Aug 19 10:42:23 c13 kernel: usb 3-1: new full speed USB device using uhci_hcd and address 7
Aug 19 10:42:29 c13 kernel: usb 3-1: device not accepting address 7, error -71
Aug 19 10:42:29 c13 kernel: usb 3-1: new full speed USB device using uhci_hcd and address 8
Aug 19 10:42:34 c13 kernel: usb 3-1: device descriptor read/64, error -71
Aug 19 10:42:39 c13 kernel: usb 3-1: device descriptor read/64, error -71
Aug 19 10:42:39 c13 kernel: usb 3-1: new full speed USB device using uhci_hcd and address 9
Aug 19 10:42:45 c13 kernel: usb 3-1: device descriptor read/64, error -71
Aug 19 10:42:50 c13 kernel: usb 3-1: device descriptor read/64, error -71

I had this issue in a previous build (r18365?), and it now seems to work as expected in r18380.
I wonder if r18370 may have fixed this issue.

I just noticed this problem with lockups and USB on my e260 and decided to try an upgrade to r18383 to see if it solves the problem. For me, it doesn’t. The USB connect screen comes up and then all controls go unresponsive. I think I tried a ‘lsusb’ on the Ubuntu 7.10 system to which I had connected the e260 and I don’t think the e260 even appeared in the list of connected devices. Disconnecting the USB cable had no effect. I had to force a power off.

To follow up on my previous comment, it works for me on r18380 and r18403, doesn’t work for me on r18390

For what it’s worth, it seems the daily build version of r18390 works as expected for me.
I suspect this is an issue with certain compiler versions but not others.

For what it’s worth, after further discussion on IRC, I think I’m barking up the wrong tree and wasting everybody’s time.
Sorry about that.

I’m also experiencing this problem. I’m using rockbox version r18864-081023 on a sansa e280. Is there any validity to using a different build?

I would like to add a “me too” post. The Stable 3.0 build on my Sansa e260 did not have this problem. Plugging in the USB while Rockbox was booted would cause the screen to do a disconcerting fade out and reboot. I loaded r19029-081106 and now doing so causes the screen to appear corrupted and hang. Have to hold down the power button for some time to get the player to shut off.

If I plug in the USB cable while the player is off it boots to the embedded firmware just fine.

I’m wondering if the code removed by r19277 caused freezes on usb plugin.
I still think that certain build toolchains built code with this bug and other compiler toolchains didn’t.

just want to mention: not working on r19748. usb charging works (when pressing select on connect) just fine.

did this ever work?
it never worked for me (so either there are some models with problems or i somehow did never use the releases where it should have worked).

Has r19819 fixed this issue?

MikeS commented on 2009-01-25 18:08

The reboot code needed to be moved to IRAM which seemed to stop the dodgey reboot where sometimes it would work and sometimes wouldn’t. I suspect the memory controller being reset while running from mapped RAM which might or might not take execution to a place where it simply freezes rather than looping (my best guess ATM for the reason).

Can this be closed then? I just asked if the people reporting this bug still experience it.

MikeS commented on 2009-01-25 19:32

Probably. I experienced it and the fix seems to work.

this still happens to me on r19857. so it is obviously not yet fixed or there are several errors.

as soon as i connect the usb (without pressing to “charge only”) the player switches to the usb icon and then the display becomes white and the player hangs completely.
no own compilation, downloaded r19857 from

The problem with any “fix” is that this only seemed to occur for certain builds. It’d fail to work in an official build, but when I built the exact same revision, it worked.
For what it’s worth, on both the e200 and the mini2g, I don’t experience this issue on r19856 because Rockbox doesn’t even recognize that USB has been plugged in, just that the charger is connected.

sorry, i meand 19853. didnt test with 19857 yet, but as nothing changed in between regarding usb this obviously wont matter much.

The c200 also doesn’t recognize USB being connected with r19856

The USB failure I’m experiencing would be connecting to a box running Debian Sid with a 2.6.26 kernel.

And it (sort of) works on the e200 and c200 when connected to a XP SP3 box.


Available keyboard shortcuts


Task Details

Task Editing