FS#924 - Hebrew font and lang error

Attached to Project: Rockbox
Opened by Anonymous Submitter - Friday, 14 February 2003, 18:25 GMT
Last edited by Jonas Häggqvist (rasher) - Wednesday, 14 September 2005, 21:02 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


after installing a new (compiled from cvs) ajbrec.ajz ( ver
030214-1935 date 14/2/2003) for my 20G archos
jukebox recorder (JBR20101) with ROM firmware 1.28,
the hebrew lang and font are not working any more all I
see is very strange letters in the file names (font) and in
the menus (lang).
this was ok in the release of the 1.4 that I had before.

This task depends upon

Closed by  Jonas Häggqvist (rasher)
Wednesday, 14 September 2005, 21:02 GMT
Reason for closing:  Fixed
Comment by Anonymous Submitter - Wednesday, 30 April 2003, 05:48 GMT

I can confirm it, didn't find any font which works with
Comment by Anonymous Submitter - Saturday, 19 July 2003, 13:04 GMT

Yeah, I've got the same model with the same problem. This
can easily be fixed by adjusting the ASCII keys of the four
hebrew fonts, cause the hebrew letters are obviously there. I
would have fixed the problem if I knew the format of the fnt
files. But I don't, so...

Anyway, here's my E-mail:
Comment by Björn Stenberg (zagor) - Thursday, 20 November 2003, 00:06 GMT

Since I don't read hebrew, I need som data to work with. Can someone
post/send a simple text in hebrew and an image showing what it should
look like?

Also, are filenames displayed wrong too or only menus etc?
Comment by Gadi Cohen (gadicohen) - Monday, 24 May 2004, 14:45 GMT Comment by Jonas Häggqvist (rasher) - Saturday, 27 August 2005, 15:10 GMT

Have you tried recent builds which include a patch for
hebrew display (and a fix for convbdf which may also have

Does the problem still exist?
Comment by lshachar (lshachar) - Wednesday, 14 September 2005, 19:27 GMT

Yo Bacon_boy!

have you just replied a one and a half year old followup?

the whole tracker is two and a half year old :P

I'm using hebrew language on my ihp120 player, and looking
at the archos simulator, it seems to work for them too.
Comment by Jonas Häggqvist (rasher) - Wednesday, 14 September 2005, 21:02 GMT

I assumed so. Closing.