Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category ID3 / meta data
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Eddie - 2008-08-04
Last edited by Dominik Riebeling - 2008-08-19

FS#9240 - Problem with the ID3 info on my Gigabeat F40

Hi, I’m having some problems while I’m listening music. Some of the song when I listen to them, it doesn’t show the Id3 (song’s name), just a ? mark instead. The rest of the info such as Album or Artist are ok.
The weird thing is that I spent the whole weekend fixing all the Id3 of each song of my collection, using Mp3Tag and saving each Id3 as Id3v2.3 ISO-8859-1. Then, when I transfer again and replaced all the song of my gigabeat, I found out the problem is still there. Anyone knows what’s going on?

Closed by  Dominik Riebeling
2008-08-19 22:02
Reason for closing:  Out of Date
Additional comments about closing:  

no response from reporter, plus it looks like an issue with the tags itself. If you still have problems please discuss in our support channels first (irc, forums, mailing lists) to ensure there is actually a bug.

Thomas Martitz commented on 2008-08-04 02:16

Use UTF-8 tags (not ISO-8859-1), you probably have problems with non-unicode chars.

Dominik Riebeling commented on 2008-08-04 06:08

This sounds more like double tags (i.e. id3v2 and id3v1) being present with mismatching information. Please keep in mind that we do not provide support in the tracker, and this really looks like a support issue to me.

kugel: if it was a non-unicode issue only the affected characters should show up funny. The tag itself shouldn't show only a question mark. Using latin1 for tags is absolutely ok.

Eddie commented on 2008-08-04 22:24

Thanks for your help. However, I'm still confused. Dominik Riebeling (bluebrother), you said that I have double tags. (Id3v1 and Id3v2), and you're right about it. Which one do you want me to keep? I'm sure that both Id3 has the same information. I'll give you an example

This is the information on both Id3

Artist: Guster
Song: Airport Song
Album: Goldfly
Track #: 4
1998

However, in my Gigabeat appears like this:
Artist: Guster
Song: ?
Album: Goldfly
Track # 4
1998

As you see, there is no special carachters (latin characters)
Let me know what else do you need

p.s: I'm not smart enough LOL

Eddie commented on 2008-08-04 22:38

Thomas Martitz (kugel.) Thanks for your help, I tried saving the tags (UTF-8) but it didn't work. I still don't get why am I having problems.

Dominik Riebeling commented on 2008-08-05 17:20

Eddie, I still believe there is something strange with your tags. Please try removing all tags from the file but the v2.3 – if that doesn't help please try removing all v2 tags leaving the v1.

Dominik Riebeling commented on 2008-08-13 21:02

any news on this?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing