Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by agaffney - 2008-08-07
Last edited by nls - 2008-12-02

FS#9250 - UI freeze when playing one particular song

I’ve been running rockbox for 2-3 months on my Sansa e260. I’ve tried 3 different builds, the latest from ~3 weeks ago.

I’ve been getting what I thought to be random freezes. When it happens, the UI is completely unresponsive aside from hitting a button to turn on the screen or holding down the power button for 10s to shut it off.

However, it doesn’t become unresponsive all at once. Usually, the volume will still work for a few seconds after the Prev/Next navigation stops working. But it eventually all stops working.

It seems to be one particular MP3 file on my player that causes this freeze. I’ve had it happen with two different random playlists, and it also happens with a playlist of *just* this one file.

The file in question can be found at the following URL. It’s the only file in the directory.

http://www.creativecommunications.com/misc/rockbox/

Closed by  nls
2008-12-02 12:51
Reason for closing:  Works For Me
Additional comments about closing:  

Unable to reproduce and the test file is gone. Request a reopen or open a new bugreport if this is still an issue.

CFP commented on 2008-08-07 17:52

Could not reproduce this problem on my Gigabeat F, or in Sansa simulator.

When I reproduced it with just the single file in a playlist, I had to hit Next once it started playing, and then it happened.

nls commented on 2008-08-07 20:59

I could not reproduce this with only that file in a playlist on either c200 or in a sim.

Is there anything I can do to debug this on my player?

CFP commented on 2008-08-07 21:03

Tried my best and eventually managed to stop the sound but this is already reported as another bug and whichever repeat mode I use I could’nt reproduce.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing