Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by imaginal - 2008-08-08
Last edited by bertrik - 2010-07-18

FS#9256 - "Recently Added" always Empty

After proper initialization, the “Recently Added” section never populates with any files. Please reference the following post for more details.

http://forums.rockbox.org/index.php?topic=18072

Closed by  bertrik
2010-07-18 21:06
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed by SVN r27484, you may have to re-initialise your database for the "Recently Added" feature to start working properly.

CFP commented on 2008-09-01 21:32

Same bug on my Gigabeat F60

I have Ipod Nano (1st gen) and I also never see anything in “Recently Added” I have seen this but in all Rockbox 3.1 and all prior versions in last 1.5 year!
I would love to help fix this issue also just tell me how can I help.

Is there anyway we can give you some more feedback so that this bug gets fixed?

I had some issues with my ipod nano so I did whole clean reinstall of rockbox.

1. formated all partition of Ipod nano
2. restored apple firmware via Apple Itunes to Nano
3. installed latest Rockbox via rbutil under linux to Nano (themes failed in install!)
4. saved some tracks to Nano
5. under database set these settings: Load to RAM: Yes ; Auto Update: No ; Gather Runtime Data: Yes
6. rebooted nano
7. looked under “Recently Added”

Still nothing there.

Do you need more feedback so that this bug gets fixed?

I now see added tracks… hmm… maybe that was needed was to delete the old database and start over.

Does this work also when you have database update set to automatic? I will also check if it works ok when it is set to automatic…

I can confirm this bug on Sansa Fuze.

Could some of you give more information about this bug ?
For example, you say that you add files but nothing shows up in “Recently Added” ⇒ this is normal if Auto Update is set to No because in this case the added files are not added to the database.
However, this is a bug if you add files and, either because you have ‘Auto Update’ or because you select ‘Update Now’, the file is added to the database but does not show up in recently added.

This “bug” could also be due to the fact that the database sometimes delay commit to the next reboot, so perhaps one reboot is necessary for the section to be populated but I’m not entirely sure about this.

What I normally do when I add new files to the devices:
- add files
- boot rockbox
- wait a little
- reboot (files are committed to DB)

The new files do show up in the database, but never in Recently Added.

I’ve attached a file created by settings_dumper

meh… that is not a representation of the current settings at all, is it
anyway to dump those to file as well?

A two year old bug report, but I still see this on my Sansa Fuze v1. Nothing in the list of recently added songs. I have auto-update turned on.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing