Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category ID3 / meta data
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Peter D. - 2008-08-18
Last edited by Andree Buschmann - 2011-01-30

FS#9299 - BBC dowload ID3v2.3 tags not read reliably

I am quite prepared to believe that this is fundamentally a BBC problem.

Amarock can extract; title, artist, album, genre, year, and a very long comment from “Material World” downloads. Rockbox r18310-080818 can only extract the ID3 version (2.3) and the first three letters of the album name (Mat).

mp3info claims that there are no version 1.x tags in the offending files.

http://www.bbc.co.uk/radio/podcasts/material/

Closed by  Andree Buschmann
2011-01-30 20:24
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with r29174.

Admin
Linus Nielsen Feltzing commented on 2008-08-18 13:26

This is most likely caused by the long comment tag. For some reason, Rockbox still doesn’t read more than 300 bytes from the ID3 tag, despite the Metadata-On-Buffer system.

Paul Louden commented on 2008-08-18 14:17

When you say “can only extract” do you mean the database, the ID3 info screen for the file, or in the WPS?

Admin
Frank Gevaerts commented on 2008-08-18 14:40

I’ve seen this as well (also with BBC mp3s). It is “solved” by removing the APIC tags

Peter D. commented on 2008-08-19 01:14

I was only looking at the WPS. It looked a bit suspect, so I created a custom WPS that just displays the ID3 tags described in the manual.

$ cat Test.wps

%wd

%s%ac%?ia<%ia|Artist Unknown>
%s%ac%?ic<%ic|Composer Unknown>
%s%ac%?id<%id|Album Unknown>
%s%ac%?ig<%ig|Genre Unknown>
%s%ac%?in<%in|Track Num Unknown>
%s%ac%?it<%it|Track T Unknown>
%s%ac%?iv<%iv|ID3 ver Unknown>
%s%ac%?iy<%iy|year Unknown>

I didn’t think to look at the file properties screen. (I didn’t realize that ID3 data was there.) Path, Name, Size, Date, and Time look good. Artist and Title are blank. And Album has only the first three letters.

The database has entries for “Mat” and “Mate”. I assume different truncations of “Materials World”.

Jonas Häggqvist commented on 2008-08-19 01:23

This file (http://downloads.bbc.co.uk/podcasts/radio4/material/material_20080814-1800.mp3) also includes a rather large (53544 bytes) APIC frame (”album art”).

Magnus Holmgren commented on 2008-08-19 20:05

I’d bet that removing the APIC frame made no difference at such. Re-ordering the frames is a more likely explanation (so perhaps you got album and artist but not title). A small edit of any field is likely to have the same effect.

Increasing the ID3v2 buffer could help, yes (in the linked file, the comment alone is almost 600 bytes). Why not do it for SWCODEC targets at least?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing