Rockbox

Tasklist

FS#9324 - "Pause" WPS icon shown instead of "Stop" icon when playback stopped

Attached to Project: Rockbox
Opened by Shiloh Hawley (gree665) - Tuesday, 26 August 2008, 05:59 GMT
Last edited by Paul Louden (Llorean) - Tuesday, 26 August 2008, 07:35 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The title says it all: the WPS used to display the 'stop' icon when you pressed stop (briefly before the display showed the file browser). Now it shows the 'pause' icon. Im using the current rev, not sure when it broke.
This task depends upon

Closed by  Paul Louden (Llorean)
Tuesday, 26 August 2008, 07:35 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Pause Icon is apparently supposed to display during fade-out.
Comment by Paul Louden (Llorean) - Tuesday, 26 August 2008, 06:43 GMT
What icon shows depends on the WPS you're using. Are you sure your current WPS is even designed to show a stop icon?
Comment by Shiloh Hawley (gree665) - Tuesday, 26 August 2008, 06:55 GMT
Yes and I checked it with the default Cabbie theme as well, which also should show the stop icon.
Comment by Paul Louden (Llorean) - Tuesday, 26 August 2008, 06:58 GMT
Actually, the WPS should be left instantly when stop occurs, there should never be time for the "Stop" icon to display.

What exact SVN revision are you using?
Comment by Paul Louden (Llorean) - Tuesday, 26 August 2008, 07:00 GMT
As a note, I am unable to reproduce this bug as described on a Gigabeat F.
Comment by Shiloh Hawley (gree665) - Tuesday, 26 August 2008, 07:16 GMT
I am using version 18342 from today, with all of the default options (I removed my .rockbox folder and downloaded it fresh). All the versions for the last few weeks at least have had this behavior.

The WPS is not left instantly when the stop occurs, for me, it is displayed for a full second after pressing the 'stop' button. During this time, the 'pause' icon is on the screen (used to be the 'stop' icon). I have 2 Gigabeat F's and both of them have this behavior.

Of course it is not a big deal, but it does annoy me.
Comment by Paul Louden (Llorean) - Tuesday, 26 August 2008, 07:19 GMT
So you're saying that with completely reset settings, on a current build, both of your Gigabeats stay in the WPS for an entire second before leaving?

What format files are you playing? Does it do this no matter what file you play? What screen are you returning to when you leave the WPS?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 26 August 2008, 07:25 GMT
Couldn't it be that Fade On Stop is enabled?
Comment by Paul Louden (Llorean) - Tuesday, 26 August 2008, 07:34 GMT
Ah, yes. And apparently the code says it's supposed to show the Pause icon during fadeout. So while it's not the behaviour it used to be, this is apparently what is intended according to commit history and comments and not a bug.

Loading...