Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Shiloh Hawley - 2008-08-26
Last edited by Paul Louden - 2008-08-26

FS#9324 - "Pause" WPS icon shown instead of "Stop" icon when playback stopped

The title says it all: the WPS used to display the ‘stop’ icon when you pressed stop (briefly before the display showed the file browser). Now it shows the ‘pause’ icon. Im using the current rev, not sure when it broke.

Closed by  Paul Louden
2008-08-26 07:35
Reason for closing:  Not a Bug
Additional comments about closing:  

Pause Icon is apparently supposed to display during fade-out.

Paul Louden commented on 2008-08-26 06:43

What icon shows depends on the WPS you’re using. Are you sure your current WPS is even designed to show a stop icon?

Shiloh Hawley commented on 2008-08-26 06:55

Yes and I checked it with the default Cabbie theme as well, which also should show the stop icon.

Paul Louden commented on 2008-08-26 06:58

Actually, the WPS should be left instantly when stop occurs, there should never be time for the “Stop” icon to display.

What exact SVN revision are you using?

Paul Louden commented on 2008-08-26 07:00

As a note, I am unable to reproduce this bug as described on a Gigabeat F.

Shiloh Hawley commented on 2008-08-26 07:16

I am using version 18342 from today, with all of the default options (I removed my .rockbox folder and downloaded it fresh). All the versions for the last few weeks at least have had this behavior.

The WPS is not left instantly when the stop occurs, for me, it is displayed for a full second after pressing the ‘stop’ button. During this time, the ‘pause’ icon is on the screen (used to be the ‘stop’ icon). I have 2 Gigabeat F’s and both of them have this behavior.

Of course it is not a big deal, but it does annoy me.

Paul Louden commented on 2008-08-26 07:19

So you’re saying that with completely reset settings, on a current build, both of your Gigabeats stay in the WPS for an entire second before leaving?

What format files are you playing? Does it do this no matter what file you play? What screen are you returning to when you leave the WPS?

Admin
Linus Nielsen Feltzing commented on 2008-08-26 07:25

Couldn’t it be that Fade On Stop is enabled?

Paul Louden commented on 2008-08-26 07:34

Ah, yes. And apparently the code says it’s supposed to show the Pause icon during fadeout. So while it’s not the behaviour it used to be, this is apparently what is intended according to commit history and comments and not a bug.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing