Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Clément Pit--Claudel - 2008-08-28
Last edited by Marianne Arnold - 2008-09-02

FS#9335 - Bug in large playlists handling

I recently encountered a quite annoying bug :
→ Go to Database, Artist, All, and play a file. Wait for all the files to be added (this is not needed though, the bug still appears if you stop the creation of the playlist)
→Now try to edit the current playing list by moving songs around.

When selecting the song, another playlist entry appears just before the actually selected one and gets moved instead of the right one. When you validate the move, it disappears and gets replaced by the track you wanted to move.
Furthermore, if you cancel by pressing ‘back’ button, the cursor jumps to the actual position of the track that had appeared. Sometimes, an empty tack is inserted, probably because the part of the playlist it comes from has not been loaded yet. Only verified on Gigabeat, not tested on other targets.

CFP.

Closed by  Marianne Arnold
2008-09-02 08:44
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of  FS#7967  .

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing