• Status Closed
  • Percent Complete
  • Task Type Patches
  • Category Applications
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by krz - 2008-08-31
Last edited by Domonoky - 2008-09-03

FS#9344 - Mutlitarget WPS Editor

This patch enables ability to switch different targets on runtime. Currently not all targets available.

Closed by  Domonoky
2008-09-03 19:25
Reason for closing:  Accepted
krz commented on 2008-08-31 16:24

Added comment highliting, added error handling, added debug output. From now default build will be “debug”. README tels how to build release.

it looks like the diff contains some files (almost) completely unchanged – looks pretty much like a line ending issue to me. Please make sure to ignore line endings when creating diffs (diff -b) so they only contain the real changes.

Apart from what bluebrother said, the patch looks nice.

One of the missing things is, the automatic build of the libs.
You could change the build command for libwps in the to call the buildall shell script… :-)

Also it seems its only possible to build libwps libs for colour targets. But that can be fixed later.

using a shell script for building the various libwps versions doesn’t sound like a good idea to me – you get a dependency to a sh-compatible shell, and on w32 you most probably won’t have one installed. IMO it would be much better using a list with targets to build and trying to use wildcard matching.

krz commented on 2008-09-02 13:44

New build system. Bat-files for win, sh-files for lunix.

You forgot to include qsyntaxer.cpp in your diff…

Next to that I still get these error messages:
9 libs found
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“” “h10_5gb”
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“ERR: failed to resolve <get_model_name>”
“” “unknown”
“ERR: failed to resolve <get_model_name>”
“” “unknown”

A fix for this is (I’m too lazy to make a one-line patch):
change l.225 in qwpsdrawer.cpp to this:

QString modelName = getModelName(qApp→applicationDirPath()+”/”+libs[i].fileName());

Building on MingW on Windows seems to be broken for me (using buildall.bat), I can only build by doing ‘qmake && make release’ in gui & gui/src/QPropertyEditor manually..

I took the liberty of adding some extra syntax rules with coloring/formatting.
What do you think?

krz commented on 2008-09-03 17:32

Now qsyntaxer.cpp is included :)

Error “ERR: failed to resolve <get_model_name>” is solved.

To build on mingw you should add your Qt/bin and mingw/bin dirs to PATH and run script from Qt command line.

Your syntax highliting added.


Available keyboard shortcuts


Task Details

Task Editing