Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Bootloader
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by nls - 2008-09-06
Last edited by bluebrother - 2009-03-19

FS#9369 - Bootloaders for 3.0 please test

This is a batch of bootloaders built from the 3.0 branch. I don’t have any of these players myself so I can’t test, only players which are recoverable from a bad bootloader are included (not sure about the gigabeat though) so no h100/h300.
The most notable fix is proper support for CF modded targets so if you have one of them any test results would be extra nice, ipod nano is included because the official bootloader uses some kind of nasty hack that was later fixed in the code, no other flash based targets for now.
The archos bootbox is not included either, I’ll try to look into that.

Please test these and report success/failure here.

edit: pp5020.mi4 is for the m:robe 100 other file names should be self explanatory

Closed by  bluebrother
2009-03-19 18:32
Reason for closing:  Out of Date
Additional comments about closing:  

3.0 is out since a while and we now have  FS#9955  . Superseded.

nls commented on 2008-09-06 10:02

bootbox .ucl’s for the various achos targets

* mini2g with CF card mod: No problems. Rockbox runs fine and OF boots (can’t check further as no itunesdb)
* mr100: no issues
* e200: no issues.

Tested the Gigabeat bootloader just now (FWIMG01.DAT) (on an F10), and it fails to work properly.

The ‘gigabeat’ logo screen loads, then hangs with the progress bar about halfway full, and shortly after, the logo screen shows what looks like TV interference; seemingly random ‘static’ of some sort, which in turn becomes vertical lines, still over the initial ‘gigabeat logo’ screen. It all finishes with a dark grayish-colored screen that fades to white.

I’ve hard-reset the player and watched this three separate times while typing this; same result each time.

I’m not sure if it makes any difference, but I’m using the modified/shortened bootloader files to decrease boot time (can’t find the page on rockbox.org right now, though, strangely enough. I’ve used those files and the old bootloader for quite a few months without updating).

Its OF is v3.0, the Japanese version, if that’s useful to know…

Also, the bootloader does not enter the normal recovery mode when started with the USB cable plugged in, however, it does turn off (when plugged in) at the point when it otherwise faded to a white screen.

(The trick with opening and hot-plugging the hard disk and reverting the bootloader should fix it, though; and I’ve done it before… shouldn’t be a problem.)

I’ll see if the bootloader continues to fail with all of the original boot files in place and report back if something changes…

No such luck… with all original firmware files in place (besides the supplied bootloader from this page), the Gigabeat continues to fail to boot. Back to the older bootloader for me… I’ll watch this task for at least a few days in case I can be of any additional help/assistance in fixing this bug.

Admin
fg commented on 2008-09-07 13:57

* ipod video 5G 30GB (your bl): works
* ipod mini 2G CF-modded (transcend 32GB) (your bl): works
* sansa c200 (self-built bl): works
* AJB 6000 (self-built archos.mod): doesn’t work
* X5L (your bl): works
* Gigabeat F60 (your bl and self-built): doesn’t boot

* ipod nano (your bl): works

* ipod color (unmodded, 40GB, your bl): works

I just committed some work to fix the Gigabeat F/X bootloader. I would post my build, but I think it would be better if a 3rd party verified it.

* ipod mini1g (unmodded, your bl): works

nls commented on 2008-09-11 15:49

Thanks for all the testing people!

Karl, great work!
Is that fix suitable for the 3.0 branch? It would be nice to have it on the branch so all bootloaders could be built directly from there.

Thanks,
It doesn’t change anything functionally so I think it would be fine to include in the 3.0 branch. I do not know how to commit to that branch though.

Tried with Ipod Video modded with AData Speedy 32Gb.
Still get ATA Error: -1

nls commented on 2008-09-15 13:48

Here is a new gigabeat f bootloader built from the branch with Karl’s fix applied, if it works I will commit the fix to the branch.

edit: deleted the file, new one posted further down

The new Gigabeat bootloader works.

*H10_20GB: works

iPod Color works great. I notice no difference between it and the current one. Just for kicks I thought I would add this, just in case there’s a question that the below info answers:

C:\ipodboot>ipodpatcher -a bootloader-ipodcolor.ipod
ipodpatcher v2.0 with v2.0 bootloaders - (C) Dave Chapman 2006-2007
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

[INFO] Scanning disk devices… [INFO] Ipod found - Photo/Color (”winpod”) - disk device 7
[INFO] Reading partition table from \\.\PhysicalDrive7
[INFO] Sector size is 512 bytes
[INFO] Part Start Sector End Sector Size (MB) Type
[INFO] 0 63 80324 39.2 Empty (0×00)
[INFO] 1 80325 39063022 19034.5 W95 FAT32 (0x0b)
[INFO] Ipod model: Photo/Color (”winpod”)
[INFO] Checksum OK in bootloader-ipodcolor.ipod
[INFO] Reading original firmware… [INFO] Wrote 5440000 bytes to firmware partition
[INFO] Bootloader bootloader-ipodcolor.ipod written to device.

Admin
fg commented on 2008-09-21 18:06

I re-tested on sansa c200. The current bootloader has broken usb detection

iPod 5GB: this bootloader version has proper contrast. The version installed by current rbutilqt has poor contrast. Neither versions boot rockbox properly (”File Not Found”). iPod firmware does boot with the hold switch on. rockbox.ipod is present at $IPOD_ROOT/.rockbox/rockbox.ipod

creation details:

filesystem:
sudo mformat -t 1189 -h 255 -s 32 -F i:

bootloader:
[INFO] Scanning disk devices… [INFO] Ipod found - 1st or 2nd Generation (”winpod”) - /dev/disk2
[INFO] Reading partition table from /dev/disk2
[INFO] Sector size is 512 bytes
[INFO] Part Start Sector End Sector Size (MB) Type
[INFO] 0 63 80324 39.2 Empty (0×00)
[INFO] 1 80325 9780748 4736.5 W95 FAT32 (0x0b)
[INFO] Ipod model: 1st or 2nd Generation (”winpod”)

nls commented on 2008-09-30 08:31

ok, new batch of ipod bootloaders, build from the latest branch code and with correct version string :)

iPod 4G Color works great, no problems that I can find. I’m using a hard drive (wish I could test CF card :D)

[INFO] Scanning disk devices… [INFO] Ipod found - Photo/Color (”winpod”) - disk device 7
[INFO] Reading partition table from \\.\PhysicalDrive7
[INFO] Sector size is 512 bytes
[INFO] Part Start Sector End Sector Size (MB) Type
[INFO] 0 63 80324 39.2 Empty (0×00)
[INFO] 1 80325 39063022 19034.5 W95 FAT32 (0x0b)
[INFO] Ipod model: Photo/Color (”winpod”)
[INFO] Checksum OK in bootloader-ipodcolor.ipod
[INFO] Reading original firmware… [INFO] Wrote 5434368 bytes to firmware partition
[INFO] Bootloader bootloader-ipodcolor.ipod written to device.

Best thing is, this appears to be smaller than the last one :) Thanks for your work!

iPod 5GB: contrast is still good, still “File Not Found”.

nls commented on 2008-10-01 15:24

Bill, good to heat that it’s no worse but I have no idea what’s causing your problem so I would suggest trying to get into our irc channel and asking there, it is where the people who would be able to figure that out is most likely to be.

Once again thanks for testing everyone :)

Admin
fg commented on 2008-10-06 18:47

Works fine on ipod video (5G 30GB) and ipod mini (2G 32GB CF)

Working fine on my iPod video as well (5.5G 30GB).

vanni commented on 2008-10-08 23:39

Working great with the new bootloader on my iPod mini 2G with 32gb CF card. Thanks!
When will the new bootloader be used by the Rockbox utility?

Tested the iPod color and iPod 2G bootloaders. Both boot successfully.

iPod G1 works properly too. Tried booting rockbox and OF, plus verbose mode

Rockbox Utility uses the latest released bootloader, so once the bootloader gets officially release they will get used.

nls commented on 2008-10-10 15:37

nano tested by llorean and working fine so i think it’s time we put these up on the official download site, but we need updated ipodpatchers too.
Here’s the linux one.
Edit: this is a 32 bit version.
Edit2: forgot to mention that this is only tested to see that it runs, i don’t have any ipods to test it with…

   ipodpatcher (397.1 KiB)
Admin
fg commented on 2008-10-10 15:53

Here’s an untested windows binary (r18760, but with main.c:34 says 3.0)

nls commented on 2008-10-10 16:44

And here is a 64 bit version, not tested with any ipod, just tested that it runs at all.

   ipodpatcher (401.3 KiB)

Here’s a tested OS X binary. So far I tested it on a PowerBook G4 with 10.4.11 Tiger.

My 4G iPod color and 5.5G iPod video both got detected.

Admin
fg commented on 2008-10-10 17:05

The 32-bit linux one works here

vanni commented on 2008-10-10 17:54

The Windows version of ipodpatcher works with both my iPod mini 2G (standard 4GB hard drive) and my iPod mini 2G (4GB CF card).

The windows version works nicely on my Ipod Nano 1Gen 2gb…

Robert’s dmg worked fine on my intel mac and nano

kfazz commented on 2008-10-15 12:57

ipod 3g bootloader works on my CF modded 3rd gen (transcend 133x 8gb)
rockbox itself seems to have problems writing to the card, but that’s a different story.
it boots but apparently freezes on writes

nls commented on 2008-10-15 20:35

Zip of all the ipod bootloaders for convenience when building ipodpatcher.

Project Manager

All these are now on the download master server. Should be generally available within 60 minutes.

nls commented on 2008-10-15 21:07

New gigabeat f bootloader, built from the same rev as for the ipods now with version string “3.0” (the previous one didn’t have a proper version so i went with 3.0 to be consistent).

Looks like this task is almost done - can I suggest it stays open until the H100/H300 bootloaders (any others?) are done too? ;-)

nls commented on 2008-10-16 08:24

sure, but we are not done for a while yet.
Hd based players that have still not had a new bootloader are: (excluding h100/h300)
iaudio: x5, m5, m3
iriver: h10, h10-small
mrobe: mr100
(it seems amiconn is working on the archoses)

we might want to release a new one for the sansas too which would also require new sansapatchers.

n1s clearly knows as we tested it in IRC, but I tested the latest gigabeat F bootloader and it works fine too.

FYI - I just flashed my H300 with an SVN bootloader (r18818M) and it seems to work fine.

My H300 is of the variety that never gives a working bootloader USB mode with the v5 bootloader, with either the original 40GB drive, or the current 80GB Toshiba drive (an MK8007GAH, IIRC).

(Note that the M in the revision is purely a mistake where I’d removed a couple of DEBUGF() lines from albumart.c…)

I’ll be adding a Mac OS X version of Sansapatcher soon. All testers to make sure it’s a proper universal binary are welcome.

Edit – And here it is. Tested with my c240 on a PPC Mac with OS X 10.4.11; bootloader installed successfully.
Edit 2 – Deleted the disk image; will build a new version shortly.

nls commented on 2008-10-16 21:22

Here are new sansa bootloaders, PP5022.mi4 is for e200, firmware.mi4 for c200.
the slightly larger sansapatcher is for 64 bit linux the smaller one 32 bit.
Version string for the new bootloaders is 5.0 (older e200 bootloader was 4.0)
Sansapatcher is now 0.7

The patchers are just tested to see that they run, not tested with actual installation, bootloaders are not tested at all.

nls commented on 2008-10-16 22:41

e200r bootloader

New OS X Sansapatcher using the new e200/c200 firmwares rolled by Nils Wallménius.

Test to your heart’s content. :)

works fine on intel leapord

Admin
fg commented on 2008-10-23 13:54

Sansapatcher windows build. It runs in wine, but untested on a real windows PC with sansa attached

sansapatcher.exe tested on real w2k:
Uninstalling bootloader v4: OK
Installing bootloader v5: OK
bootloader v5 works: OK
Sansa e250

vanni commented on 2008-11-01 23:24

Although the new bootloaders work fine on all iPod mini 2G (either with microdrive or with CF card) and on iPod mini 1G with microdrive, they do NOT work on iPod mini 1G with CF flash card. I tested today with a 8GB CF card on an 1G iPod mini and found the system hanging after booting and switching from the apple screen to the Rockbox screen. Strangely, an old Rockbox 2 version with the old bootloader (September 2008) runs without problems on this device.

Project Manager

The last seven sansa files are now on the download server

should this task be closed ? (out of date)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing