Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by fg - 2008-09-08
Last edited by teru - 2009-07-09

FS#9383 - chessclock freezes on deleting a player

To reproduce :
start chessclock
choose two players
choose any time value you like
once everything is setup, get the menu
select Delete player
press any button
The player is now frozen

Reproduced on ipod video, ipod mini, H120, gigabeat F, X5, and Archos player

Closed by  teru
2009-07-09 13:42
Reason for closing:  Accepted
Additional comments about closing:  

committed as r21733. thanks.

I confirmed this bug.

I send the patch file.
Please confirm it.

sync r20338

teru commented on 2009-06-03 13:16

I noticed one issue in Uchida’s patch.
if a player is deleted, switching to previous player is not work properly.
e.g.
1. start with 3 players.
2. delete one of them. e.g. 2nd player.
3. now, 3rd player is displayed.
4. press button to show previous player. player is not changed.
i think 1st player should be displayed.
here is a patch that enables to show previous player.
Could someone confirm this?

Hi, Kawashima, thank you for the report about another problem.
I confirmed this problem.
Because your patch file is baesed on  FS#9707 , I corrected it to this task’s patch (chessclock_2.patch).
I corrected the patch of  FS#9707  too. Please look at  FS#9707 .


sync r21316

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing