Rockbox

Tasklist

FS#9384 - Bug in "Fade on Stop/Pause

Attached to Project: Rockbox
Opened by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 06:57 GMT
Last edited by Paul Louden (Llorean) - Tuesday, 09 September 2008, 13:37 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If I activate "Fade on Stop/Pause" in the Playback Settings, and press UP in the WPS and then DOWN, the WPS is shown until the music is completely silent, and then rockboxs jumps to the menu.

I don't know whether its understandable, I'm German....
This task depends upon

Closed by  Paul Louden (Llorean)
Tuesday, 09 September 2008, 13:37 GMT
Reason for closing:  Later
Additional comments about closing:  Not a bug, but not necessarily ideal. This may be addressed at a future time if this architectural quirk can be addressed well.
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 07:38 GMT
What exactly are you calling the bug here?

Your description sounds like you're saying "It displays the While Playing Screen until the music actually stops playing." Could you describe not only what happens, but what you expected to happen?
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 09:06 GMT
i see:

UP
DOWN
|in this time you see the wps
|and the music becomes more quiet
| "
| "
music stops completely
then the menu is shown


i expect
UP
DOWN
the menu is shown
|in this time the music becomes more quiet
|but the menu is shown and you can navigate through it
|
|
music is completely silent


the problem is that the player dont react if you press UP until the music is totally silent.

i hope this was better^^
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 09:11 GMT
What does "Up" or "Down" have to do with pausing the music or going to the menu? The navigational buttons should just adjust volume in the WPS.

Please, use the button names from the manual if you don't mean the navigation buttons.
Comment by Jonathan Gordon (jdgordon) - Tuesday, 09 September 2008, 09:41 GMT
im guessing he is on e200 so DOWN is the menu and UP is pause?

anyway, this should be closed "not a bug"... fade on pause/stop is done in such a way that you are stuck in the WPS untill its finished... I guess it could be moved to the playback thread but thats complex enough as it is and its "good enough" how it is now
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 10:50 GMT
sorry again, ts on the sansa e200, UP is play/pause and DOWN is menu, right.

"that you are stuck" you said it i think this is a bug.
Comment by Frank Gevaerts (fg) - Tuesday, 09 September 2008, 12:17 GMT
If I want to listen to music I have to boot the player, and it's stuck in the bootloader for a few seconds. Is that also a bug?
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 12:44 GMT
when i listen music and want to go to the menu its stuck... is that also a bug?

sorry i thought you would search for bug for 3.0 but if you always say "in my opinion it works fine" then you need not to appeal for bughunting... i think even those subtle (? i mean little) bugs can be fixed.
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 12:49 GMT
So are you saying you can't get to the menu?

I'm confused, above you sound like it just waits for the fade before you can go to the menu. Now you're saying it's stuck?

I'm assuming you just mean still that it's delayed, but I'd like to be certain.
Comment by Frank Gevaerts (fg) - Tuesday, 09 September 2008, 12:54 GMT
I agree that this is not perfect, however doing this otherwise would compilcate the playback code a lot. This may look like a little bug from a user perspective, but trying to change this would have serious risks of destabilizing the code, so it certainly won't be changed for 3.0
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 13:01 GMT
sorry again, ts on the sansa e200, UP is play/pause and DOWN is menu, right.

"that you are stuck" you said it i think this is a bug.
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 13:04 GMT
im sorry for repeating my comment... please ignore the last one^^

@paul: i dont know whether i can say its stuck for a while, but frank gevaerts did so. i mean its only delayed, yes.

@frank: ok i see^^

Loading...