Rockbox

Tasklist

FS#9385 - Battery: 1% != 10min

Attached to Project: Rockbox
Opened by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 07:05 GMT
Last edited by Paul Louden (Llorean) - Tuesday, 09 September 2008, 11:08 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

in rocbox-info there is:
Battery: 86% 14h 20m

this means that 1% is equal to 10 minutes... but this is wrong. you could modify this so that a realistic time is shown, and you could display a different time when music is played.


I don't know whether its understandable, I'm German. So please ask if its not clear:)
This task depends upon

Closed by  Paul Louden (Llorean)
Tuesday, 09 September 2008, 11:08 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Just a complaint that the battery calibration doesn't exactly perfectly match his used battery.
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 07:39 GMT
You haven't mentioned what player this happens on, nor any other information about the state of the battery or what exactly is going wrong or what you expected.
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 07:43 GMT
sorry... sansa e280. and i expected a realistic time how long the battery has energy, not 10mins per 1%.
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 07:45 GMT
What do you mean by "realistic"?

Have you performed a battery benchmark on your player? Maybe your battery is old, and that's why you're not getting as much as it predicts. Also, the prediction is based on an assumed usage habit that doesn't involve frequent button presses or lighting of the screen.
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 09:15 GMT
i dont know the real times. provided that the battery of the sansa e280 lasts for 12 hours. then 1% would be 7.2min. i expect that the player calculates with this time.
but the player calculates with 1%=10 min, so the battery would last for 16,6 hours, which is wrong.

i dont know how long the battery lasts, but i know that those 16,6 hours are too much.

and when music is played, the battery becomes flat faster. so a different time should be shown.
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 09:49 GMT
Some people have reported 20 hours. I would actually say that 16.6 hours might be a little on the low side for expected actual runtime with a fresh battery under good conditions.

If you don't know how much the battery actually lasts, how do you know it's too much? And the time is for when music is playing.
Comment by Johannes Linke (Jaykay) - Tuesday, 09 September 2008, 11:01 GMT
when you own a player long enough you get a feeling how long the battery lasts... i.e. on a 6h drive i heard music without doing much with the player. at the beginning rockbox showed 100%, at the end about 55%, i dont know exactly. my player is half a year old.

and information which are based on best conditions, with some patches, a fresh battery and the player wasnt touched while he played doesnt help. especially when every 7minutes, when you do much with the player every 5, this information is reduced by 10 minutes.

rockbox could measure (?) the time needed for a few percent, calculate the average and calculate the remeining time.
Comment by Paul Louden (Llorean) - Tuesday, 09 September 2008, 11:08 GMT
So, what you're saying is "I haven't done a battery bench, nor spent any real time comparing the approximated time remaining with the real time remaining, and my battery is at a minimum six months old plus whatever shelf time."

This isn't a bug, this is the feature working as intended and you requesting it work in a different way.

Loading...