Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Frank Gevaerts - 2008-09-09
Last edited by Jonathan Gordon - 2012-02-07

FS#9391 - playback engine gets confused by multiple simultaneous button presses

Easiest way to reproduce:

seek forward in a file. Don’t release the seek button
press play button, and keep pressed
release seek button
release play button

Now the WPS still shows the seek icon, but the progress bar doesn’t advance and no music plays. No button works until you seek again.

(seen on c200, ipod mini and x5l)

Closed by  Jonathan Gordon
2012-02-07 11:07
Reason for closing:  Fixed
Additional comments about closing:  

in a2f2845

Thomas Schott commented on 2008-09-10 09:41

Reproduced with exact the same behaviour on ipod color.

Tomasz Wasilczyk commented on 2008-09-15 21:55

on c200 (r18359) there is the same problem. I also noticed:
- power (long press) and hold buttons works properly
- backlight works ok: it turns off after one minute and turns on after pressing any button (but that button makes no other action)

Boris Gjenero commented on 2009-03-30 06:06

Reproduced on 30GB 5G iPod running r20573 and playing an MP3 album.
Sequence is: 1) press seek button, 2) press menu, centre or play/pause button, 3) release seek button, 4) release other button
Seeking stops when the other button is pressed. Only way out seems to be power off or seeking. Regardless of the seek button pressed, the first seek is in the same direction as the original seek.
If the other button is released before the seek button (ie. steps 3 and 4 are reversed) seeking resumes when the other button is released, and everything is normal afterwards.

I’ve also encountered similar playback freezes by quickly seeking back and forth, without pressing two buttons at the same time. (That’s how I found this FS task.) Beginning a seek while the previous seek icon is still on the WPS can cause the old seek icon to remain until the end of the new seek (possibly showing the wrong seek direction). I don’t know if these are related to this task.

Austin Appel commented on 2009-05-01 06:57

Reproduced on an iriver H300 running r20820 playing a wavpack recording.
Sequence seems to be 1) press and hold seek button, 2) press + and navi at roughly the same time 3) release buttons
Then appears frozen with same experience as dreamlayers - Only way out seems to be power off or seeking. Regardless of the seek button pressed, the first seek is in the same direction as the original seek.

Steve Bavin commented on 2011-04-28 13:30

Has this been resolved by the recent playback rework?

Michael Sevakis commented on 2011-04-30 13:40

Possibly not, since the WPS code handles keypresses, not the playback engine.

Steve Bavin commented on 2011-05-01 11:49

You’re correct - I can easily reproduce it in a simulator.

Looks like the ffwd_rew() code in wps.c is the problem. If it isn’t factored out completely, it should at least be static (and maybe button should be a long too)….

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing