Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by pondlife - 2008-09-29
Last edited by fg - 2010-01-22

FS#9429 - Pictureflow segfaults with a particular image

When running pictureflow on my H300, it locks the device occasionally.

Having tried it on the sim, under gdb, I can reproduce the following error (and back-trace):

Program received signal SIGSEGV, Segmentation fault.
[Switching to thread 2264.0x33c]
0x04f031ef in render_slide (slide=0x4f12598, result_rect=0x351facc, alpha=110, col1=219, col2=219)

  at pictureflow.c:1243

1243 *pixel1 = fade_color(ptr[p1 » PFREAL_SHIFT], alpha4);
(gdb) bt
#0 0x04f031ef in render_slide (slide=0x4f12598, result_rect=0x351facc, alpha=110, col1=219,

  col2=219) at pictureflow.c:1243

#1 0x04f039fc in render_all_slides () at pictureflow.c:1407
#2 0x04f04fbb in SDL_main () at pictureflow.c:2011

I noticed that the initial pictureflow scan stops during the letter P (i.e. albums beginning with P), so suspect that this crash occurs when it later attempts to render an album past this point. Not sure how to go about diagnosing it further though, so any pointers would be welcome.

Closed by  fg
2010-01-22 20:58
Reason for closing:  Out of Date
Additional comments about closing:  

Reopen if there's more information

Is this still happening? If yes, we should investigate the image.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing