Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Waldo000000 - 2008-10-02
Last edited by fg - 2008-12-29

FS#9441 - Erratic button lights on Olympus M:Robe 100 (MR100)

On M:Robe 100, after bootup, button lights at first seem to function properly (i.e. they turn on when you press buttons, they turn off after a timeout). But after a few seconds of navigating menus normally, the lights go out, and do not turn on again when you press a button. From that point forward (until you reboot the device), the button lights are very erratic - in general, they do not turn on again, but sometimes flicking the hold switch or pressing the power button or other buttons brings the lights back to normal operation for a while, or just makes them flash momentarily.

Update: sometimes the button lights malfunction immediately on startup, before a button has even been pressed.

This is an issue in the current build as well as the 3.0 release.

Closed by  fg
2008-12-29 12:12
Reason for closing:  Not a Bug
Additional comments about closing:  

As requested :)

Admin
fg commented on 2008-10-08 18:34

I’ve tried to reproduce this on my mr100 with r18662-080928 (which is somewhere between the builds you tried), and everything seems to work fine

I cannot reproduce this either with Rockbox 3.0

Hey guys, thanks for your feedback.

I’ll try the latest version some day soon, and if that works fine I’ll join you in recommending closure of this bug.

Do you experience any problems with the button lights when using the OF?

@Justin: Absolutely not

I just installed release 3.1 with the util, and the operation of the button lights appears much improved, but there are still problems.

On one occasion, I was playing around with the player and the lights were turning on/off as expected, but then i put the player on hold for about 5 mins, and when I came back, took the player off hold, and started pressing up/down/left/right again, the lights failed to come back on. This was fixed after I again put the player on hold, then took it back off of hold, after which normal function was restored.

I’ll continue to use the player and see if I can pick up any trends i.e. to narrow down in what situations there are malfunctions.

Ok, my bad, it’s looking more like it’s a hardware problem. Not surprising really, I guess. I’ll do some more testing with the OF.

Heh, fix = give the player a firm tap. The unfortunate coincidence seems to be that a hardware fault has come about at pretty much exactly the same time I’ve switched from OF to rockbox.

Feel free to close this bug. Thanks, Roy.

FYI, interestingly, the same hardware fault is reported by this other guy using OF as “the button screen does not light up like it used to, unless I apply pressure”, here: http://www.reviewsbycole.com/2008/06/olympus-mrobe.html

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing