Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by lfaraone - 2008-10-11
Last edited by Domonoky - 2009-05-09

FS#9474 - Rbutil fails when a ".rockbox" file exists on the player

Steps to reproduce:
1) Set the target (in the qt gui) to a otherwise empty folder with a .rockbox file in it.
2) Click “Install Rockbox”

A “cannot create directory” error is given.

Ideally, rockbox would detect that there is a file there, as it currently does if you have a directory there.

Closed by  Domonoky
2009-05-09 23:56
Reason for closing:  Wont Fix
Additional comments about closing:  

as long as it failes with a error message, this isnt a bug.

If there's a .rockbox folder, the utility can add its files to it non-destructively (making the assumption that any duplicate files are meant to be overwritten).

If a file, .rockbox, exists the utility probably shouldn't overwrite it because it's probably there for a reason. It's not the same situation.

Is the bug the fact that the utility doesn't destroy files in its way, or what?

Well, in the directory case, a prompt is given asking if the old .rockbox directory should be archived or removed.

This problem confused me for a while, since my disk had filesystem errors, and after running checkdisk the OS replaced the corrupted .rockbox directory with a binary file of what it could recover.

So, yes, it would have been nice for a prompt to appear asking if the file could be removed.

I don't think the Rockbox Utility should be doing this. At the most, it could say "cannot create directory - a file named .rockbox already exists" instead, but I think this could be closed as well.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing