Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Infrastructure → Build environment
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Bartosz Fabianowski - 2008-11-26
Last edited by Nils Wallménius - 2008-11-26

FS#9579 - Fix compilation when build directory is not inside rockbox source directory

The most recent change to wps/wpsbuild.pl introduced a bug that makes “make zip” fail if the build directory is not directly inside the rockbox source directory. The attached patch fixes this.

The problem is that $firmdir is set to “$ROOT/firmware” before the final value of $ROOT has been determined using GetOptions(). This way, $firmdir always is “../firmware”, regardless of the root directory passed in via the -r option.

Closed by  Nils Wallménius
2008-11-26 09:43
Reason for closing:  Accepted
Additional comments about closing:  

committed, thanks!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing