Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Jaykay - 2008-12-19
Last edited by bertrik - 2010-09-26

FS#9681 - button queue should be cleared after some splashes

to reproduce:

1. enable dircache. when you enabled it already, disable it first.
2. while it says “please reboot to enable” press some buttons.

youll see that all actions for the pressed buttons will be done after the splash disappears. same thing with all other splashes i.e. “loading….”.

its not much work to add this clear button queue :)

btw: 2 seconds are imo too long for this splash, the time should be decreased. in general at splashes which just give information you should be able to cancel them with a button press.

sansa e280+r19396

Closed by  bertrik
2010-09-26 21:22
Reason for closing:  Rejected
Additional comments about closing:  

Not a bug. Besides, button_clear_queue() would be a rather crude fix for this.

This splash is important enough that we want to make sure people read it. People still miss it even with the two seconds it’s onscreen. Reinitializing the database shouldn’t be something you do so often that waiting 2 seconds is really a significant inconvenience. This one specifically should definitely not be able to be canceled.

ok, forget about the two seconds, and look at the first part ;)

If it’s not much work, why don’t you supply a fix?

guess what, i dont know how. but i know there exists button_clear_queue(), so it shouldnt be much work (for those who know how to do it, of course). you can also wait for a fix by me, but i guess it will take some months….

took it out of the “simulator” group because this affects real targets also.. but very unlikely that anything will be done about it…

In my opinion, the current behaviour is not a bug, it executes your actions just as you directed by pressing buttons, only a little delayed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing