Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Johannes Linke - 2008-12-21
Last edited by Teruaki Kawashima - 2009-07-21

FS#9692 - cant save the file after "changes NOT saved" in text editor

to reproduce it:

1. open text_editor in the application-menu.
2. press down to show the menu of the editer.
3. select “save” 4. enter nothing, but press play.
5. it should say “changes NOT saved” 6. after that you can do what you want, every time you try to save something it says “changes NOT saved” directly after pressing “Save”.

workaround: restart text_editor :)

expected behaviour: when selecting “save” in 6., the editor should give you a second chance to save the file.

Closed by  Teruaki Kawashima
2009-07-21 14:54
Reason for closing:  Fixed
Additional comments about closing:  

fixed in r21994.

Johannes Linke commented on 2008-12-21 12:21

i forgot again: sansa e280 + r19396.

can anybody change the category to plugins?

Yoshihisa Uchida commented on 2009-01-21 09:21

I create the patch file.

Please confirm it.

Yoshihisa Uchida commented on 2009-01-22 10:35

I correct my patch file a little.

Johannes Linke commented on 2009-01-23 21:28

i corrected the patch file also a little, thre was a mistake in the path and i changed a splash.

with this patch the bug does no longer happen.

can someone commit & close this?

Yoshihisa Uchida commented on 2009-01-24 02:32

In the comment that uses IRC, because the possibility that your comment disappears in other opinions is high
because time zone that you and I are acting is not suitable, my comment write here.
(I confirmed your IRC comments for about 30 minutes ago.)

When file open failure, I change the message as “Can not save !!”.
In this case, I thought that the message should be modified because error occurs, the text was not saved
and it is not correct that the message is “Changes NOT saved” because the user did not cancel the preservation processing.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing