Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by woodensoul - 2008-12-27
Last edited by speachy - 2021-05-12

FS#9719 - Playback skips and hangs badly on iPod Video 80GB on start up

This is a recurring problem with this target it seems. With 3.1 installed and resume playback on start up enabled, playback hangs and skips badly while the hard drive is being scanned during start up.

The same behavior occurs when resume on start up is disabled, but playback is resumed by the user during the hard drive scan.

Closed by  speachy
2021-05-12 21:20
Reason for closing:  Out of Date
Additional comments about closing:  

Doesn't seem to be relevant for current builds.

ajb commented on 2008-12-27 17:24

I've seen similar behaviour but I wasn't sure if it was a symptom of the battery being low.

This is definitely not a symptom of the battery being low. It happens with a fully charged battery.

Do you have DirCache enabled, and/or Database Load To RAM? If so, could you see what happens if you disable one of those (and disabling the other one; and disabling both) to see what the effect is? I've noticed a certain amount of 'thrashing' on startup (more disk seeking than I would expect from just buffering alone - I'm guessing due to DirCache and/or Database) and perhaps on a particularly fragmented filesystem this prevents buffering from taking place in a timely fashion

I am seeing the same problem with current svn builds on my 80gb ipod video when ever I enable DirCache. Disabling the Directory Cache and restarting my player fixes the problem here.

I also have the database enabled and and the database ram cache switched on.

jc commented on 2009-06-18 03:07

I have a similar and perhaps the same issue with an 80GB ipod video. Playback will pause for a second and then play for 3-5 and then pause, then play… If I pause playback with a pause button press and wait for drive activity to quiet down I can then resume proper playback. It will happen with "resume on startup" and be fine for a varying amount of time before having issues again. I have tried disabling dircache and database to ram, enabling and disabling all sorts of settings (car adapter mode, pause/resume on headphone unplug/plug) and even completely removed and reinstalled with defaults. No fix yet… any ideas?

Can someone confirm that this still occurs with the Ipod Video?

jc commented on 2011-04-26 15:26

Yes, this still happens on my iPod Video 80GB model. I think there was a problem with buffering of FLAC files that was fixed. It corrected the issue for standard bit-rate FLAC files, but the buffering problem still happens with 24-bit FLAC files. The same "fix" resolves it… pause playback for 5-10 seconds and resume play.

I tested r30369 on my iPod Video 30GB with m4a, mp3, mpc and high-bitrate alac. I cannot reproduce the described issue for those formats when enabling "resume on startup". Is this an effect that is specific for 24bit-FLAC?

jc commented on 2011-09-26 01:49

This problem used to affect FLAC as well, but since upgrading to the most recent stable release it only affects 24-bit FLAC. I haven't tested other formats.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing