Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#9747 : Last.fm log sets bogus tracknumber when not set in the tag

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To
    obo
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by rasher - 2009-01-02
Last edited by rasher - 2009-01-08

FS#9747 - Last.fm log sets bogus tracknumber when not set in the tag

As the summary says, when the tag doesn’t set a tracknumber, the scrobbler.log contains a weird value instead of simply leaving it out as the format specifies (http://www.audioscrobbler.net/wiki/Portable_Player_Logging): “# If the data for optional fields is not available to you, leave the field blank (\t\t).”

Closed by  rasher
2009-01-08 22:28
Reason for closing:  Invalid
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

I can't reproduce - maybe I was just looking at the wrong stuff. I'll keep an eye on it

obo commented on 2009-01-04 15:02

I can’t reproduce this - creating test tracks with no track number field just result in “\t\t” in the log. QTScrobbler didn’t handle that though (it assumed there would be an int present), so I’ve commited a change there. What I did notice is that the RB scrobbler logging doesn’t use track_string (string version of tracknum in the RB mp3entry struct), but I’m looking into changing that.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing