Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#9792 : Improvements needed for newly-added c200/e200 charging patch.

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System Sansa c200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by gnafuthegreat - 2009-01-13
Last edited by saratoga - 2009-01-13

FS#9792 - Improvements needed for newly-added c200/e200 charging patch.

The charging patch detailed in  FS#8363  (http://www.rockbox.org/tracker/task/8363) does not allow for playback while charging on my v1 c240, and it is unintuitive to initiate charging. I have installed from today’s daily build (r19752) and the charging seems to be working well (thanks a lot for the work on this!).

In respect to music playback during charging, the only reason I need charging in the Rockbox interface is so that I can continue listening to my music while charging (my music is in Vorbis format, so using the OF is not an option). In addition, playback does not work until I unplug the USB cable and reboot the player.

As far as it being unintuitive, I would like to see improvements to its implementation. Currently, plugging in the USB cable outside of the battery screen reboots the player into the OF. Also, plugging the USB cable into the player while off boots into the OF (I believe this is a property of the bootloader). I would like it to stay in Rockbox and begin charging when I insert the cable, regardless of what screen I’m on or what I’m doing. I believe that people who need to access the internal memory will know to hold down the left arrow to boot into the OF. Otherwise, we should expect people are just plugging in to charge and what it to stay in Rockbox. Perhaps a setting for how you want it to behave would be good, though I believe the default could be as I have described (but that’s just me). If there’s already a setting for this, forgive me and please direct me to it.

So, in summary, I would like to be able to plug my c240 into a USB port, while playing music in Rockbox, and have the music continue playing, uninterrupted, while the unit begins to charge.

I’m not a programmer, and I’m certainly not making demands. I know the best way to get this functionality would be to do the work myself, but I really can’t. I’m just voicing some suggestions and hoping they get implemented as time goes by. Thank you so much for the work you’ve done so far and for implementing even rudimentary charging support. I’ve been watching the development with glee and was only waiting until it was available in a daily build to try it.

If I can offer any further information, let me know. If some of the things I mentioned above are limitations of other parts of the system undergoing changes and have nothing to do with the charging patch itself, then I’m sorry for implicating it.

Closed by  saratoga
2009-01-13 15:26
Reason for closing:  Not a Bug
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Changing how buttons work is a feature request, not a bug report so please don't file it as one. Furthermore, theres basically no way this would be accepted without working rockbox USB.

If you hold select while connecting the player it should charge and not reboot.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing